Mailinglist Archive: opensuse-security-announce (17 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:1317-1: important: Security update for jasper
SUSE Security Update: Security update for jasper
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:1317-1
Rating: important
References: #725758
Cross-References: CVE-2011-4516 CVE-2011-4517
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


The following issue has been fixed:

* Specially crafted JPEG2000 files could cause a heap
buffer overflow in jasper (CVE-2011-4516, CVE-2011-4517)

Security Issue references:

* CVE-2011-4516
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4516
>
* CVE-2011-4517
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4517
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-jasper-5523

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-jasper-5523

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-jasper-5523

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-jasper-5523

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

libjasper-devel-1.900.1-134.11.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):

libjasper-1.900.1-134.11.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64):

libjasper-32bit-1.900.1-134.11.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):

libjasper-1.900.1-134.11.1

- SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64):

libjasper-32bit-1.900.1-134.11.1

- SUSE Linux Enterprise Server 11 SP1 (ia64):

libjasper-x86-1.900.1-134.11.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

libjasper-1.900.1-134.11.1

- SUSE Linux Enterprise Desktop 11 SP1 (x86_64):

libjasper-32bit-1.900.1-134.11.1


References:

http://support.novell.com/security/cve/CVE-2011-4516.html
http://support.novell.com/security/cve/CVE-2011-4517.html
https://bugzilla.novell.com/725758

http://download.novell.com/patch/finder/?keywords=471159bc08512078fa6cf62f71f0d41a

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages