Mailinglist Archive: opensuse-security-announce (17 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:1292-1: important: Security update for xorg-x11-server
SUSE Security Update: Security update for xorg-x11-server
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:1292-1
Rating: important
References: #722944
Cross-References: CVE-2011-4028 CVE-2011-4029
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


This update fixes two security issues with the X server:

* A local attacker could find out if a file exists by
exploiting the way that Xorg creates its lock files.
(CVE-2011-4028
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4028
> )
* A non-root local user could set the read permission
for all users on any file or directory. (CVE-2011-4029
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4029
> )

Indications:

Please install this update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-xorg-x11-Xvnc-5479

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-xorg-x11-Xvnc-5479

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-xorg-x11-Xvnc-5479

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-xorg-x11-Xvnc-5479

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

xorg-x11-server-sdk-7.4-27.40.52.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):

xorg-x11-Xvnc-7.4-27.40.52.1
xorg-x11-server-7.4-27.40.52.1
xorg-x11-server-extra-7.4-27.40.52.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):

xorg-x11-Xvnc-7.4-27.40.52.1
xorg-x11-server-7.4-27.40.52.1
xorg-x11-server-extra-7.4-27.40.52.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

xorg-x11-Xvnc-7.4-27.40.52.1
xorg-x11-server-7.4-27.40.52.1
xorg-x11-server-extra-7.4-27.40.52.1


References:

http://support.novell.com/security/cve/CVE-2011-4028.html
http://support.novell.com/security/cve/CVE-2011-4029.html
https://bugzilla.novell.com/722944

http://download.novell.com/patch/finder/?keywords=a425a7733f910d0e1b72d89e91656ce9

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages