Mailinglist Archive: opensuse-security-announce (34 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:1215-1: important: Security update for Apache2
SUSE Security Update: Security update for Apache2
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:1215-1
Rating: important
References: #688472 #693479 #713966 #719236 #722545
Cross-References: CVE-2011-3192
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
______________________________________________________________________________

An update that solves one vulnerability and has four fixes
is now available. It includes one version update.

Description:


This update brings Apache to version 2.2.12.

The main reason is the enablement of the Server Name
Indication (SNI) that allows several SSL-enabled domains
on one IP address (FATE#311973). See the
SSLStrictSNIVHostCheck directive as documented in
/usr/share/apache2/manual/mod/mod_ssl.html.en

Also the patch for the ByteRange remote denial of service
attack (CVE-2011-3192) was refined and the configuration
options used by upstream were added.

Introduce new config option: Allow MaxRanges Number of
ranges requested, if exceeded, the complete content is
served. default: 200 0|unlimited: unlimited none: Range
headers are ignored. This option is a backport from 2.2.21.

Also fixed were

* CVE-2011-3348: Denial of service in proxy_ajp when
using a undefined method.
* CVE-2011-3368: Exposure of internal servers via
reverse proxy methods with mod_proxy enabled and incorrect
Rewrite or Proxy Rules.

This update also includes a newer
apache2-vhost-ssl.template, which disables SSLv2, and
allows SSLv3 and strong ciphers only. Please note that
existing vhosts will not be converted.

Security Issue references:

* CVE-2011-3192
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3192
>

Indications:

Please install this update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-apache2-5344

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-apache2-5344

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-apache2-5344

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64) [New Version: 2.2.12]:

apache2-devel-2.2.12-1.18.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 x86_64) [New
Version: 2.2.12]:

apache2-2.2.12-1.18.1
apache2-doc-2.2.12-1.18.1
apache2-example-pages-2.2.12-1.18.1
apache2-prefork-2.2.12-1.18.1
apache2-utils-2.2.12-1.18.1
apache2-worker-2.2.12-1.18.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64) [New Version:
2.2.12]:

apache2-2.2.12-1.18.1
apache2-doc-2.2.12-1.18.1
apache2-example-pages-2.2.12-1.18.1
apache2-prefork-2.2.12-1.18.1
apache2-utils-2.2.12-1.18.1
apache2-worker-2.2.12-1.18.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64) [New
Version: 2.2.12]:

apache2-2.2.12-1.18.1
apache2-doc-2.2.12-1.18.1
apache2-example-pages-2.2.12-1.18.1
apache2-prefork-2.2.12-1.18.1
apache2-utils-2.2.12-1.18.1
apache2-worker-2.2.12-1.18.1


References:

http://support.novell.com/security/cve/CVE-2011-3192.html
https://bugzilla.novell.com/688472
https://bugzilla.novell.com/693479
https://bugzilla.novell.com/713966
https://bugzilla.novell.com/719236
https://bugzilla.novell.com/722545

http://download.novell.com/patch/finder/?keywords=274b1ea87316767c995b46d30d848997

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages