Mailinglist Archive: opensuse-security-announce (31 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:1035-1: important: Security update for Xorg X11
SUSE Security Update: Security update for Xorg X11
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:1035-1
Rating: important
References: #709851
Cross-References: CVE-2011-2895
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


Specially crafted font files could cause a buffer overflow
in applications that use libXfont to load such files
(CVE-2011-2895).

Security Issue reference:

* CVE-2011-2895
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2895
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-libpciaccess0-5103

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-libpciaccess0-5103

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-libpciaccess0-5103

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-libpciaccess0-5103

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

libpciaccess0-devel-7.4-8.26.3.1
xorg-x11-devel-7.4-8.26.3.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (ppc64 s390x x86_64):

xorg-x11-devel-32bit-7.4-8.26.3.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):

libpciaccess0-7.4-8.26.3.1
xorg-x11-libs-7.4-8.26.3.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64):

libpciaccess0-32bit-7.4-8.26.3.1
xorg-x11-libs-32bit-7.4-8.26.3.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):

libpciaccess0-7.4-8.26.3.1
xorg-x11-libs-7.4-8.26.3.1

- SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64):

libpciaccess0-32bit-7.4-8.26.3.1
xorg-x11-libs-32bit-7.4-8.26.3.1

- SUSE Linux Enterprise Server 11 SP1 (ia64):

libpciaccess0-x86-7.4-8.26.3.1
xorg-x11-libs-x86-7.4-8.26.3.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

libpciaccess0-7.4-8.26.3.1
libpciaccess0-devel-7.4-8.26.3.1
xorg-x11-devel-7.4-8.26.3.1
xorg-x11-libs-7.4-8.26.3.1

- SUSE Linux Enterprise Desktop 11 SP1 (x86_64):

libpciaccess0-32bit-7.4-8.26.3.1
xorg-x11-libs-32bit-7.4-8.26.3.1


References:

http://support.novell.com/security/cve/CVE-2011-2895.html
https://bugzilla.novell.com/709851

http://download.novell.com/patch/finder/?keywords=243cfa96e18e5e50f1a5b1fee95d0ae9

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages