Mailinglist Archive: opensuse-security-announce (31 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:1029-1: important: Security update for pure-ftpd
SUSE Security Update: Security update for pure-ftpd
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:1029-1
Rating: important
References: #685447 #699300 #700335 #703035
Affected Products:
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that contains security fixes can now be
installed. It includes one version update.

Description:


The OES Netware add-ons in pure-ftpd had a security problem
and some bugs, which are fixed by this update.

A local attacker could overwrite local files when the OES
remote server feature of pure-ftpd is enabled due to a
directory traversal. ( CVE-2011-3171)

Additionally the following bugs have been fixed:

* bnc#699300 - FTP remote server navigation does not
always succeed
* bnc#685447 - pure-ftpd does not throw an error when
the name resolution fails during remote server navigation
* bnc#700335 - put files into NCP volumes fails
* bnc#703035 - remote_server feature opens a
vulnerability with directory traversal & file overwriting

Indications:

Please install this update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-pure-ftpd-5091

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-pure-ftpd-5091

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-pure-ftpd-5091

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64) [New Version:
1.0.22]:

pure-ftpd-1.0.22-3.13.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64) [New
Version: 1.0.22]:

pure-ftpd-1.0.22-3.13.1

- SUSE Linux Enterprise Server 10 SP3 (i586 ia64 ppc s390x x86_64):

pure-ftpd-1.0.22-0.26.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64) [New Version: 1.0.22]:

pure-ftpd-1.0.22-3.13.1


References:

https://bugzilla.novell.com/685447
https://bugzilla.novell.com/699300
https://bugzilla.novell.com/700335
https://bugzilla.novell.com/703035

http://download.novell.com/patch/finder/?keywords=c52bd104fe2da41024af9337e1af6c2e

http://download.novell.com/patch/finder/?keywords=dd45c5f4faa971592d516df47b6195b0

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages