Mailinglist Archive: opensuse-security-announce (30 mails)

< Previous Next >
[security-announce] openSUSE-SU-2011:0943-1: important: libmodplug: Fixed multiple vulnerabilities reported in <= 0.8.8.3
openSUSE Security Update: libmodplug: Fixed multiple vulnerabilities
reported in <= 0.8.8.3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0943-1
Rating: important
References: #710726
Cross-References: CVE-2011-1761 CVE-2011-2911 CVE-2011-2912
CVE-2011-2913 CVE-2011-2914 CVE-2011-2915

Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available. It
includes one version update.

Description:

This update of libmodplug0 fixes the following issues:

1) An integer overflow error exists within the
"CSoundFile::ReadWav()" function (src/load_wav.cpp) when
processing certain WAV files. This can be exploited to
cause a heap-based buffer overflow by tricking a user into
opening a specially crafted WAV file. (CVE-2011-2911)

2) Boundary errors within the "CSoundFile::ReadS3M()"
function (src/load_s3m.cpp) when processing S3M files can
be exploited to cause stack-based buffer overflows by
tricking a user into opening a specially crafted S3M file.
(CVE-2011-2912)


3) An off-by-one error within the "CSoundFile::ReadAMS()"
function (src/load_ams.cpp) can be exploited to cause a
stack corruption by tricking a user into opening a
specially crafted AMS file. (CVE-2011-2913)

4) An off-by-one error within the "CSoundFile::ReadDSM()"
function (src/load_dms.cpp) can be exploited to cause a
memory corruption by tricking a user into opening a
specially crafted DSM file. (CVE-2011-2914)

5) An off-by-one error within the "CSoundFile::ReadAMS2()"
function (src/load_ams.cpp) can be exploited to cause a
memory corruption by tricking a user into opening a
specially crafted AMS file. (CVE-2011-2915)

Also an overflow in the ABC loader was fixed.
(CVE-2011-1761)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libmodplug-5004

- openSUSE 11.3:

zypper in -t patch libmodplug-5004

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64) [New Version: 0.8.8.4]:

libmodplug-devel-0.8.8.4-2.2.1
libmodplug0-0.8.8.4-2.2.1

- openSUSE 11.4 (x86_64) [New Version: 0.8.8.4]:

libmodplug0-32bit-0.8.8.4-2.2.1

- openSUSE 11.3 (i586 x86_64) [New Version: 0.8.8.4]:

libmodplug-devel-0.8.8.4-2.2.1
libmodplug0-0.8.8.4-2.2.1

- openSUSE 11.3 (x86_64) [New Version: 0.8.8.4]:

libmodplug0-32bit-0.8.8.4-2.2.1


References:

http://support.novell.com/security/cve/CVE-2011-1761.html
http://support.novell.com/security/cve/CVE-2011-2911.html
http://support.novell.com/security/cve/CVE-2011-2912.html
http://support.novell.com/security/cve/CVE-2011-2913.html
http://support.novell.com/security/cve/CVE-2011-2914.html
http://support.novell.com/security/cve/CVE-2011-2915.html
https://bugzilla.novell.com/710726

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages