Mailinglist Archive: opensuse-security-announce (20 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:0696-1: important: libgssglue
SUSE Security Update: libgssglue
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:0696-1
Rating: important
References: #694598
Affected Products:
SUSE Linux Enterprise Teradata 10 SP3
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 10 SP4
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 10 SP4
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:


This update fixes insecure getenv() usage in libgssglue,
which could be used under some circumstances by local
attackers do gain root privileges.

Indications:

Please install this update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-libgssglue-4620

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-libgssglue-4620

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-libgssglue-4620

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-libgssglue-4620

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Teradata 10 SP3 (x86_64):

libgssapi-0.6-13.12.1
libgssapi-32bit-0.6-13.12.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

libgssglue-devel-0.1-20.2.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):

libgssglue1-0.1-20.2.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):

libgssglue1-0.1-20.2.1

- SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):

libgssapi-0.6-13.12.1

- SUSE Linux Enterprise Server 10 SP4 (s390x x86_64):

libgssapi-32bit-0.6-13.12.1

- SUSE Linux Enterprise Server 10 SP4 (ia64):

libgssapi-x86-0.6-13.12.1

- SUSE Linux Enterprise Server 10 SP4 (ppc):

libgssapi-64bit-0.6-13.12.1

- SUSE Linux Enterprise Server 10 SP3 (i586 ia64 ppc s390x x86_64):

libgssapi-0.6-13.12.1

- SUSE Linux Enterprise Server 10 SP3 (s390x x86_64):

libgssapi-32bit-0.6-13.12.1

- SUSE Linux Enterprise Server 10 SP3 (ia64):

libgssapi-x86-0.6-13.12.1

- SUSE Linux Enterprise Server 10 SP3 (ppc):

libgssapi-64bit-0.6-13.12.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

libgssglue1-0.1-20.2.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):

libgssapi-0.6-13.12.1

- SUSE Linux Enterprise Desktop 10 SP4 (x86_64):

libgssapi-32bit-0.6-13.12.1


References:

https://bugzilla.novell.com/694598

http://download.novell.com/patch/finder/?keywords=5b5de538464acbf06386b39d37563e66

http://download.novell.com/patch/finder/?keywords=88b0a4c3666d54637f8fff06918865ef

http://download.novell.com/patch/finder/?keywords=f3c8cc7c70c0e2250dce0f068395c09e

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages