Mailinglist Archive: opensuse-ppc (14 mails)

< Previous Next >
Re: [opensuse-ppc] How to recover from missing sata_svw
  • From: "Klaas." <kplists@xxxxxxxxx>
  • Date: Mon, 08 Dec 2008 10:51:54 +0100
  • Message-id: <yam11299.2703.271456472@xxxxxxxxxxxxxx>
Op 06-dec-08 schreef Olaf Hering:

On Sat, Dec 06, Klaas. wrote:

I did a successful installation of openSuse 11.1 RC1
on my PowerMac G5 dual after I circumvented the
formatting bug.
Updated the system, ran a few tests.
Then after 2 days it would not start anymore because
the module sata_svw is missing.
Tried to start from the installation DVD with rescue
but that didn't help.
So my question : Is there a way to recover without
re-installing the system?
And from Googling I see this is a long time bug, has
anybody seen a solution?

Thank you Olaf for your answer.

Its not clear what went wrong, how and where sata_svw is missing.

I see 2 possibilities:

1. I used software update to update the new installation
maybe there went something wrong.
2. I installed a new Mac OS X on the same disk, on another
partition - very remote possibility.

Try to boot into the installer, then abort the installation.
In linuxrc, do 'Start Installation' -> 'Boot into installed system'
and see how far you get.

Did that - learned some more about Linux, but got no
result.

Run mkinitrd and lilo manually, maybe this fixes the booting issue?

Finally I decided to re-install the 11.1 - RC1 (even though a RC2
was mentioned somewhere).
I 'll forget about updates for now, but there is a very bad
bug when I shutdown. The system just stops, the screen goes
very strange and I can wait till ????
So then I will have to powerdown the system and of course
there are all kind of problems that can occur. When restarting
the system tells me it is recovering OK.

All in all a scary situation.

---
greetings,
Klaas Punt


--
To unsubscribe, e-mail: opensuse-ppc+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-ppc+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References