Mailinglist Archive: opensuse-packaging (171 mails)

< Previous Next >
Re: [opensuse-packaging] GCC regression - any hints on what should I do?
On Wednesday 07 March 2012, Ilya Chernykh wrote:
On Wednesday 07 March 2012 01:10:52 Cristian Rodríguez wrote:
There is apparent GCC regression so that a package which works
well when built with GCC-4.3 crashes if it is built with GCC-4.5
and GCC-4.6. Is there an established procedure of handling this?

btw, which package we are talking about ? show us the build log !


AFAIR some months ago I've sr'ed a "fix" against openSUSE 11.[2-4],
explicitly using gcc-4.3 instead of the current one which fixed random

If we don't have gcc-4.3 available anymore then this should be fixed
within kdepim3 itself I think.

Currently it builds with GCC-43 because kmail crashes otherwise:

this is common for all KDE3 distributions:

There is a patch that makes it not to crash when standalone, but when
this patch is applied, it crashes when embeded in kontact, even when
built with the old compiler.
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups