Mailinglist Archive: opensuse-packaging (205 mails)

< Previous Next >
Re: [opensuse-packaging] unresolvable: nothing provides device-mapper-devel-32bit
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Sat, 24 Sep 2011 16:44:07 +0200
  • Message-id: <j5kqbn$r54$1@saturn.local.net>
Marcus Meissner wrote:

On Sat, Sep 24, 2011 at 11:19:52AM +0200, Per Jessen wrote:
This is really a continuation of a thread from July:


http://lists.opensuse.org/archive/opensuse-packaging/2011-06/msg00146.html

I'm updating lilo to 23.2 - when I try to build for openSUSE 11.3 and
SLE_11_SP1, I see this error. What am I supposed to do about it, if
anything?

osc results
openSUSE_11.3 x86_64 unresolvable
openSUSE_11.3 i586 succeeded
openSUSE_11.4 i586 succeeded
openSUSE_11.4 x86_64 finished
openSUSE_Factory x86_64 finished
openSUSE_Factory i586 succeeded
SLE_11_SP1 i586 succeeded
SLE_11_SP1 x86_64 unresolvable

device-mapper-devel-32bit did not exist in regular 11.3, only
in 11.3+Updates

similar for SLE11 SP1.

Base:System has a device-mapper-devel-32bit, so you could just

osc branch Base:System device-mapper
(without doing anything else) and it will built device-mapper in your
branch and so making lilo build.

Thanks Marcus - I went ahead and did

osc branch Base:System device-mapper
A working copy of the branched package can be checked out with:

osc co home:pjessen:branches:Base:System/device-mapper

Then I did an 'osc rebuild' - which didn't change anything for 11.3 and
SLE11. I'm clearly missing something.


--
Per Jessen, Zürich (21.3°C)

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups