Mailinglist Archive: opensuse-packaging (220 mails)

< Previous Next >
Re: [opensuse-packaging] python > 2.7.1 for 11.4?
Hi;
On 06/29/2011 04:23 PM, Sascha Manns wrote:
Hello Mathias,

"Mathias Homann"<admin@xxxxxxxxxx> wrote at Wednesday 29 June 2011:

I'm still trying to package calibre>= 0.8 for opensuse.
Problems are:
1. calibre by now requires python 2.7.1 or higher but NOT python 3
2. the original author is about as cooperative and helpful as the
german tax authorities on a bad day. His general approach to any
kind of support question is "If you're not running the binaries from
my website, go eff yourself."
We have already calibre in Documentation:Tools. But we worked on the
same issues ;-)

ATM we have two packages in D:T: calibre and calibre07.
So everyone who wants for<= 11.4 he can use calibre07 which is the last
0.7.x version.
People who uses>= 11.4 and would like to have the 0.8.x Series, they
can use calibre. That Package is build against the 2.7.1 python.

Actual we must rewrite some packages in calibre, because the Sourcecode
was changed on some places.
Inside the next week(s) we hoping to present a ready calibre Package.
Also we planning to make a Announcement who explains how this tricky
work works.

None of you so far told us whats the exact problem is python 2.7 is, if you can tell us the problem then we can find a solution.

Regards.

--
Ismail Dönmez - openSUSE Booster
SUSE LINUX Products GmbH
Maxfeldstr. 5, 90409 Nürnberg, Germany
GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 16746 (AG Nürnberg)
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups