Mailinglist Archive: opensuse-packaging (192 mails)

< Previous Next >
Re: [opensuse-packaging] Re: commit jpeg8 for openSUSE:Factory
2011/4/15 Cristian Morales Vega <cmorve69@xxxxxxxx>:
2011/4/15 Ludwig Nussel <ludwig.nussel@xxxxxxx>:
Pavol Rusnak wrote:
Now that no
package uses libjpeg8 (at least on my 11.4 system), I think we can get
rid of libjpeg8 completely and rename libjpeg62-devel to libjpeg-devel.

I know of at least one program (ioquake3) that does make use of the
new libjpeg8 interfaces and will not work with libjpeg62.
Was there any progress in using symbol versioning for libjpeg8 so
a program like ioquake3 could use libjpeg8 without clashing with
other system libs?

I can't check right now. But IIRC libjpeg8 had symbol versioning from
the start (and an update for libjpeg62 was released to also add it)
thanks to Debian people. And I asked jpeg-turbo devs to also add the
symbol versioning in the ".62" soname and they agreed, so it should be
already available (I *suppose* there has been a new release).

Still, what's wrong with keeping libjpeg8-devel in case someone wants
to use it (even if we are not going to)?

Verified: In openSUSE 11.4 only libjpeg8 has versioned symbols (so
expect problems with ioquake3) but in Factory both versions use symbol
versioning.
It's a shame that openSUSE 11.4 didn't got the fix for jpeg62, but
there is little we can do now to fix it.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups