Mailinglist Archive: opensuse-packaging (216 mails)

< Previous Next >
Re: [opensuse-packaging] A .desktop file uses icon from another package
  • From: Nelson Marques <nmo.marques@xxxxxxxxx>
  • Date: Tue, 22 Mar 2011 17:22:04 +0000
  • Message-id: <AANLkTim47sEdxyOMGb9XUg0jz0dOUv=nBUJAMyCfw79J@mail.gmail.com>
On Tue, Mar 22, 2011 at 7:33 AM, Adam Mizerski <adam@xxxxxxxxxxx> wrote:
Dnia 2011-03-22, wto o godzinie 05:31 +0300, Ilya Chernykh pisze:
Hi!

I have a question. I want to a package which heavily uses icons from another
one. But the OBS system does not allow to built it: it says "icon file not
installed" even though the dependency on a package that contains the
necessary icon is included. What can I do to successfully install this
package?

Where you have the dependency? In "Requires" or "BuildRequires"?
I think that it should be in both. In "BuildRequires" to provide the
icon during install, to avoid error and In "Requires" to provide the
icon the system, where package is installed.

The best way should be that one in my opinion... include the file with
the icons as 'BuildRequires' and maybe insert a comment like:

# WARNING: package foobar as BR to share icons
BuildRequires: foobar

Anyone coming across such would easilly know what is going on.

NM


--
Adam "etamPL" Mizerski




--
Nelson Marques

/* As cicatrizes lembram-nos de onde estivemos, mas não ditam para onde vamos */
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups