Mailinglist Archive: opensuse-packaging (216 mails)

< Previous Next >
[opensuse-packaging] Re: [opensuse-factory] Coping with the recent Boost update
On Thu, Mar 17, 2011 at 04:27:02PM +0100, Philipp Thomas wrote:
Boost 1.46.0 was checked into factory not long ago (and will get an update
to 1.46.1 in the next days). The main change that wasn't mentioned in the
changes and thus escaped me was that beginning with 1.46.0 boost::filesystem
will switch its default API from v2 to v3 (see
http://www.boost.org/doc/libs/1_46_1/libs/filesystem/v3/doc/index.htm).
This will cause packages that use boost::filesystem and that don't support
v3 to fail.

There are three possible ways to fix the breakage:
1) Adapt the code to work with v3
2) Adapt the code to work with v2 or v3
3) Let the code use the v2 API.

Do we know how many packages in Factory are going to have problems with
this, or are you switching to see what it is going to be?

thanks,

greg k-h
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References