Mailinglist Archive: opensuse-packaging (284 mails)

< Previous Next >
[opensuse-packaging] pear error Parsing of package.xml from file "package.xml" failed only on SLE targets
Hi,

I've noticed some recent PHP pear packages fail only on SLE_* with an error in
parsing the pear package.xml file.

Take for example php5-pear-Crypt_Blowfish

rlang@linux-ecfn:~/build/server:php:applications/php5-pear-Crypt_Blowfish> osc
r
openSUSE_11.1 x86_64 succeeded
openSUSE_11.1 i586 succeeded
openSUSE_11.2 x86_64 succeeded
openSUSE_11.2 i586 succeeded
openSUSE_11.3 x86_64 succeeded
openSUSE_11.3 i586 succeeded
openSUSE_Factory i586 succeeded
openSUSE_Factory x86_64 succeeded
SLE-10-SP2 i586 failed
SLE-10-SP2 x86_64 failed
SLE_11 x86_64 failed
SLE_11 i586 failed
SLE_11_SP1 i586 failed
SLE_11_SP1 x86_64 failed


The relevant error section is:

+ PHP_PEAR_PHP_BIN='/usr/bin/php -d memory_limit=50m'
+ /usr/bin/pear -v -d doc_dir=/doc -d bin_dir=/usr/bin -d
data_dir=/usr/share/php5/PEAR/data install --offline --nodeps -R
/var/tmp/php5-pear-Crypt_Blowfish-1.1.0RC2-build package.xml
Parsing of package.xml from file "package.xml" failed
Cannot download non-local package "package.xml"
Package "package.xml" is not valid
install failed

How can I get a more verbose message of pear on SLE* why it thinks this xml is
broken (as opposed to even openSUSE 11.1 which should roughly equal SLE_11)?

--
Ralf Lang
Linux Consultant / Developer

B1 Systems GmbH
Osterfeldstra├če 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages