Mailinglist Archive: opensuse-packaging (242 mails)

< Previous Next >
Re: [opensuse-packaging] Tumbleweed "vendor" question
  • From: Patrick Shanahan <paka@xxxxxxxxxxxx>
  • Date: Wed, 8 Dec 2010 18:56:14 -0500
  • Message-id: <20101208235614.GA9436@xxxxxxxxxxxxxxx>
* Greg KH <gregkh@xxxxxxx> [12-08-10 18:07]:
##
## CHANGING THE DEFAULT IS NOT RECOMMENDED.
##
## Valid values: boolean
## Default value: false
##
# solver.allowVendorChange = false
#### Change ####
solver.allowVendorChange = true

Ah. Is this something that we really want to require for people using
Tumbleweed?

I've seen packages change vendors on 'zypper dup', but this only seems
to show up when there are other "normal" updates available at the same
time. Why would that time override this option?

dunnough :^) but it seems to work for me. Did you try it?

but this allows me to use multi-vendors and play semi-bleeding edge where
zypper dup (finally) caused problems of a nature similar to your case.

I still have *small* problems occasionally but of my own making.

Tumbleweed would fit my desires very well. I run a mail/web server and
much special configurating. Upgrading to a newer distro is a real PAIN.

Minor system downtime is not a problem. When/if it becomes a problem, I
will offload the server functions to a secondary machine (lazyiness is
the only thing keeping me from doing it now, and *time*).
--
Patrick Shanahan Plainfield, Indiana, USA HOG # US1244711
http://wahoo.no-ip.org Photo Album: http://wahoo.no-ip.org/gallery2
Registered Linux User #207535 @ http://counter.li.org
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups