Mailinglist Archive: opensuse-packaging (222 mails)

< Previous Next >
Re: [opensuse-packaging] rpmlint warning PreReq depricated
  • From: Vincent Untz <vuntz@xxxxxxxxxxxx>
  • Date: Wed, 7 Apr 2010 10:54:31 +0200
  • Message-id: <20100407085431.GE19886@xxxxxxxxx>
Le lundi 05 avril 2010, à 16:03 +0200, oc2pus@xxxxxxxx a écrit :
Yes, but in this case a packager can't fix it by substituting PreReq ==>
Requires(pre), this error message is triggered by using the
macro: %gconf_schemas_prereq ... and this macro is coded
in /etc/rpm/macros.gconf2
...
%gconf_schemas_prereq PreReq: /usr/bin/gconftool-2 coreutils diffutils
...

I'll fix gconf2. It's a bit annoying to have prereq in the name of the
macro, though. I think I'll leave %gconf_schemas_prereq as is and add a
new %gconf_schemas_requires macro. Any objection?

Vincent

--
Les gens heureux ne sont pas pressés.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups