Mailinglist Archive: opensuse-packaging (222 mails)

< Previous Next >
Re: [opensuse-packaging] packaging mongoDB
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Mon, 05 Apr 2010 20:02:35 +0200
  • Message-id: <4BBA25BB.7020009@xxxxxxxxxxxxx>
Hi,

Am 05.04.2010 19:46, schrieb Robert Schweikert:

I am attempting to package mongoDb and have some questions.

[...]

I linked js from the OSSP project. Initially I had an expansion error
w.r.t. the missing js-devel package. Thus I take it if I wanted mongoDB
in the distribution I'd also have to get the developers of the OSSP
project to submit the js package to the distribution, correct?

We have the Spidermonkey/Tracemonkey JS library in openSUSE already.
Please check if you can use it.
The Factory package you need to BuildRequires is
mozilla-xulrunner192-devel

If mongoDb uses pkgconfig to find the stuff everything should work if
you can point it to mozilla-js.pc.
If it's not using pkgconfig you need to take care of locating the
library yourself and use rpath to the lib location where needed.

Wolfgang
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
References