Mailinglist Archive: opensuse-packaging (218 mails)

< Previous Next >
[opensuse-packaging] Problem with renaming a package.
  • From: Dave Plater <dplater@xxxxxxxxxxxxxxxx>
  • Date: Tue, 29 Dec 2009 10:21:48 +0200
  • Message-id: <4B39BC1C.1060805@xxxxxxxxxxxxxxxx>
Hi, I maintain the rosegarden4 package in multimedia:apps and I'm busy
updating it to the latest version which I've named rosegarden-qt4 due to
the fact that it's no longer a kde3 app and has become a stand alone
qt4.5 app. I've followed the packaging guidlines for renaming a package
with "Provides: rosegarden4 = %{version}" and "Obsoletes:
rosegarden4 < %{version}" but zypper dup doesn't pick it up as an
upgrade. Fortunately kde4-kid3 has provided a possible clue because it
has also changed to kid3, rosegarden4's end version is 1.7.3 and
rosegarden-qt4's version is 10.02. These versions match the upstream
ones. Kde4-kid3 is picked up by zypper dup and the old package is marked
for removal and kid3 is marked for installation as a new package, I
suspect that rosegarden doesn't get the same treatment due to 1.7.3
having one more version digit than 10.02. I wish to maintain the same
version as upstream, what do I do in this case?
Thanks
Dave P
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups