Mailinglist Archive: opensuse-packaging (220 mails)

< Previous Next >
Re: [opensuse-packaging] Looking for volunteers to fix package dependencies
  • From: Takashi Iwai <tiwai@xxxxxxx>
  • Date: Tue, 29 Sep 2009 13:13:14 +0200
  • Message-id: <s5hd45a57hx.wl%tiwai@xxxxxxx>
At Tue, 29 Sep 2009 10:03:48 +0200,
Stephan Kulow wrote:

can't install git-arch-1.6.4.2-1.6.i586:
nothing provides tla needed by git-arch-1.6.4.2-1.6.i586

It's because tla was dropped from FACTORY.
The build of git-arch itself is done without tla. It requires tla
only for run-time. Thus, even installing is allowed without tla.

So, the possible choices are:
- resurrect tla
- disable git-arch stuff in git.spec only for 11.2 and later
(add %if %suse_version check in spec file so that git-arch will be
still built for 11.1 and older)
- simply get rid of dependency of tla from git-arch; user will notice
only when he really runs it :)


Takashi
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
References