Mailinglist Archive: opensuse-packaging (120 mails)

< Previous Next >
[opensuse-packaging] Doc files and shared library packaging (Re: /mounts/work_src_done/STABLE/libwebkit not checked in)
  • From: Vincent Untz <vuntz@xxxxxxxxxxxx>
  • Date: Fri, 31 Jul 2009 21:13:54 +0200
  • Message-id: <20090731191354.GL14341@xxxxxxxxx>
Hi,

Sending this to opensuse-packaging because I'm not sure about the
policy...

Le vendredi 31 juillet 2009, à 20:06 +0200, lrupp@xxxxxxx a écrit :
Script 'mail_helper' called by lrupp

Hi vuntz@xxxxxxxxxx,
/mounts/work_src_done/STABLE/libwebkit was not checked in by lrupp for the
following reasons:

Packaging documentation in library packages is not allowed:
http://en.opensuse.org/Packaging/Shared_Library_Packaging_Policy#Package_Contents

(note that the doc files in question are only license files + NEWS, not
API documentation, or "how to use this library" documentation)

I made the change, but I consider the policy broken here: if libwebkit11
is LGPLv2 and libwebkit12 is LGPLv3, then I can only have one
libwebkit-devel, and therefore one of those two packages won't have the
right license installed.

Can someone clarify if I'm right or wrong, and if we need to adapt a bit
the policy? :-)

Thanks,

Vincent

--
Les gens heureux ne sont pas pressés.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
List Navigation