Mailinglist Archive: opensuse-packaging (107 mails)

< Previous Next >
Re: [opensuse-packaging] When a -devel package should require another -devel package?
  • From: Cristian Morales Vega <cmorve69@xxxxxxxx>
  • Date: Thu, 28 May 2009 21:01:40 +0200
  • Message-id: <8235e6f40905281201x3a40436bp1eeddb2c2fc02db5@xxxxxxxxxxxxxx>
2009/5/28 Stanislav Brabec <sbrabec@xxxxxxx>:
Cristian Morales Vega wrote:
Well, just that.
Sometimes I find a -devel package requires another one, why? I do that
when the pkg-config file has a "Requires: XXX" and rpmlint complains
the same isn't in the RPM spec file, but normally I also don't see why
the .pc file has such an entry.

It is not a rpmlint, but an old style build check script.

There are two checks:

.pc check: Checks that all files listed in .pc are in Requires of the
rpm, so you can easily add Requires: foo-devel and everything needed is
included. Starting with rpm 4.6, this check will be obsolete, as rpm
itself will automatically require and provide these packages.

...there is any decision about when the upgrade to rpm 4.6 will be done?
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups