Mailinglist Archive: opensuse-packaging (106 mails)

< Previous Next >
Re: [opensuse-packaging] Packages that Requires: pkg-config
  • From: Cristian Morales Vega <cmorve69@xxxxxxxx>
  • Date: Thu, 28 May 2009 20:55:57 +0200
  • Message-id: <8235e6f40905281155n63c90de0q6975812a1eac08ff@xxxxxxxxxxxxxx>
2009/5/28 Cristian Rodríguez <crrodriguez@xxxxxxxxxxxx>:
Hi:

There is a very common inconsistency in packages that include *.pc
files, some do Requires: pkg-config while some others dont, I think we
need to decide to either do require it or not, and raise an error when
this policy is violated..

what you think ? should it be required or not ?

The only use case that would justify the requirement is an user
compiling manually. And that use case is already fixed if we expect
users to install the compiler through the development pattern and if
that pattern includes pkg-config (that I think already does).

So, no. If this is going to be forced I vote for not requiring it.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
References