Mailinglist Archive: opensuse-packaging (106 mails)

< Previous Next >
[opensuse-packaging] Packages that Requires: pkg-config
  • From: Cristian Rodríguez <crrodriguez@xxxxxxxxxxxx>
  • Date: Thu, 28 May 2009 14:40:09 -0400
  • Message-id: <4A1EDA89.1080504@xxxxxxxxxxxx>
Hi:

There is a very common inconsistency in packages that include *.pc
files, some do Requires: pkg-config while some others dont, I think we
need to decide to either do require it or not, and raise an error when
this policy is violated..

what you think ? should it be required or not ?

My vote is that pkgconfig is a build dependecy only, and hence -devel
packages should not require pkgconfig.



--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >