Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
Re: [opensuse-packaging] RPM Epoch
  • From: Vincent Untz <vuntz@xxxxxxxxxxxx>
  • Date: Tue, 20 Jan 2009 15:46:48 +0100
  • Message-id: <20090120144648.GI2992@xxxxxxxxx>
Le mardi 20 janvier 2009, à 15:37 +0100, Dominique Leuenberger a écrit :
On 1/16/2009 at 2:01 PM, Vincent Untz <vuntz@xxxxxxxxxxxx> wrote:
So, any idea what are the usual problems where epoch is solved, and what
are the recommended solutions?

I think a typical problem might be that you created / published a
version with a completely broken version tag (typo in the spec file).

so instead of having
VersionL 1.0.1
you wrote
Version: 10.1

In this case of course, the user will never ever get an update anymore
until the package really reaches this version.

Yep, that's the only use case I'm aware of.

This is a use-case where Epoch can help you out... (as it's just an
added version information in front of the real version).

But... what about the policy to not use Epoch? :-) Is it okay in this
case? (if yes, we should specify this)

Vincent

--
Les gens heureux ne sont pas pressés.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups