Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
Re: [opensuse-packaging] gecko-sdk
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Thu, 08 Jan 2009 10:29:11 +0100
  • Message-id: <4965C767.7070109@xxxxxxxxxxxxx>
Hi,

Lars Vogdt schrieb:
What about people just want building their apps against the "default"
mozilla-xulrunner package of a openSUSE distribution?

Tell me which is the "default" xulrunner on a specific openSUSE
distribution ;-)
IIRC we only have two in 11.0 and 11.1 and I can easily say that
xulrunner190 is the "default" on 11.1 because 181 should have been
dropped already.
For 11.0 I can't easily say what the default should be.
In theory the newest one should be the default since it's the longest
supported one, but the biggest point still is:

It's really hard to say what an application needs from xulrunner to
build. For example 1.8.1.x and 1.9.0.x are really different if
gtkmozembed is used (not speaking about the complete XRE) and an
application most likely doesn't support both.

People still can use the project config and define it just to help
packaging and if it breaks they need to use the correct package explicitely.


Wolfgang
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >