Mailinglist Archive: opensuse-packaging (98 mails)

< Previous Next >
Re: [opensuse-packaging] New ncurses version in STABLE, now with thread safe support
  • From: "Dr. Werner Fink" <werner@xxxxxxx>
  • Date: Thu, 14 Aug 2008 16:46:23 +0200
  • Message-id: <20080814144623.GA12551@xxxxxxxxxxxxx>
On Thu, Aug 14, 2008 at 10:39:20AM -0400, Jan Engelhardt wrote:

On Thursday 2008-08-14 09:32, Richard Guenther wrote:
On Thu, 14 Aug 2008, Dr. Werner Fink wrote:
On Thu, Aug 14, 2008 at 02:38:23PM +0200, Richard Guenther wrote:

Shouldn't the shared libraries be split into separate packages
and not simply grouped by .so.6.0 and .so.5.0?

Those libraries *are* splitted into separate packages, we
have libncurses5 for 5.6 and libncurses6 for 6.0.

But you have libncurses.so.5.6 and libncursesw.so.5.6 in
libncurses5 and libncursest.so.6.0 and libncursestw.so.6.0
in libncurses6, right? I was suggesting to have libncursest6,
libncursestw6, libncursesw5 and libncurses5.

That is needlessy more packages.

$ rpm -e libncurses5 2>&1 | grep libncurses.so | wc -l
33
$ rpm -e libncurses5 2>&1 | grep libncursesw.so | wc -l
12

And that's a fair share already IMHO to put them together,
like it is done in SUSE 11.0.

Di you want enforce all applications tio use the wide
character version ... even is incompatible?


Werner

--
"Having a smoking section in a restaurant is like having
a peeing section in a swimming pool." -- Edward Burr
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups