Mailinglist Archive: opensuse-packaging (140 mails)

< Previous Next >
Re: [opensuse-packaging] libraries renaming problems
  • From: Dirk Mueller <dmueller@xxxxxxx>
  • Date: Mon, 25 Feb 2008 17:23:54 +0100
  • Message-id: <200802251723.54799.dmueller@xxxxxxx>
On Monday 25 February 2008, Petr Cerny wrote:

Maybe some rpmlint check to alert when using "Requires: libfoo" appears
in .spec file would help a little bit (if there isn't such a check
already)?

there is one already, explicit-lib-dependency. perhaps we should forbit
explicit dependencies in lib packages, but looking at it, it would break 12
gnome-maintainers@ packages (and 19 packages affected in total).

disallowing explicit lib dependencies in general breaks 42 gnome packages, 78
packages in total.

Greetings,
Dirk
--
RPMLINT information under http://en.opensuse.org/Packaging/RpmLint
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >