Mailinglist Archive: opensuse-packaging (145 mails)

< Previous Next >
[opensuse-packaging] modprobe --skip-unsupported not needed anymore
  • From: Michal Marek <mmarek@xxxxxxx>
  • Date: Mon, 30 Jul 2007 13:31:49 +0200
  • Message-id: <46ADCC25.7050805@xxxxxxx>
[sorry for the cross-post, but this could be of interest for both
packagers as well as factory users/testers]

Hi,

in case you see warnings like this:

   WARNING: the --skip-unsupported option is no longer available

then either fix your package to no longer care about unsupported modules
(remove the --skip-unsupported option) or make a bugreport if it's not
in your package. Ex: https://bugzilla.novell.com/show_bug.cgi?id=293758

Background: the handling of unsupported modules was changed in 10.3,
it's now globally configured in /etc/modprobe.d/unsupported.blacklist,
it's no longer the responsibility of the callers of modprobe. For
compatibility with not yet updated scripts, the option is still
recongnized, but it prints the above warning. For details, see
http://lists.opensuse.org/opensuse-commit/2007-07/msg00513.html

have a nice day,
Michal
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages