Mailinglist Archive: opensuse-packaging (138 mails)

< Previous Next >
[opensuse-packaging] ATTN: The set of default installed packages at build time is to be reduced
  • From: Richard Guenther <rguenther@xxxxxxx>
  • Date: Fri, 23 Mar 2007 15:23:22 +0100 (CET)
  • Message-id: <Pine.LNX.4.64.0703231515180.19680@xxxxxxxxxxxxxx>

Hi,

as a heads-up (and for those curious why your package may be / has been
touched) there is an upcoming change in the set of packages installed
by default in the build environments. This can affect your packages
BuildRequires as well as requirements of pre-/post-install scripts.

The exact set of packages to be removed is not yet set in stone, but
expect the following to go:

- flex, bison
- gdbm-devel
- ncurses-devel
- libzio

and the following that may affect pre-/post-install scripts (but in
general shouldn't):

- pwdutils + its dependencies (openldap*, openssl, cyrus-sasl, ...)
- bind-libs, bind-utils
- cvs
- e2fsprogs
- libnscd
- unzip

and debugging tools such as

- procps + friends
- strace
- vim

In general we will take care of required package updates (this is why
your package is being touched).


With best regards,
Richard.

--
Richard Guenther <rguenther@xxxxxxx>
Novell / SUSE Labs
SUSE LINUX Products GmbH - Nuernberg - AG Nuernberg - HRB 16746 - GF: Markus Rex
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups