Mailinglist Archive: opensuse-packaging (53 mails)

< Previous Next >
[opensuse-packaging] Update source breaks it all..
  • From: Anders Norrbring <lists@xxxxxxxxxxxx>
  • Date: Mon, 02 Oct 2006 10:08:04 +0200
  • Message-id: <4520C8E4.8010007@xxxxxxxxxxxx>
I just added a source for updates, mirrored locally and I've run createrepo on the dir.

So, I added it in the config like this:

url_suse="file:/iscsi/Archives/SuSE/inst_source/10.1"
url_updates="file:/iscsi/Archives/SuSE/inst_source/10.1_up"
add_sources="suse updates"

So, then I tried to do a build, and this came out (hundreds of lines deleted)..

root dir set to /store3/build.root.10.1-x86_64
running from system no
ATTENTION: this is a one way ticket. Resetting this to true has not effect!
initializing installation sources ...
initializing target ...
rebuilding RPM database ..................................................... ok
reading RPM database ........................................................ ok
Known sources:
0: [x] SUSE Linux 10.1 (file:/iscsi/Archives/SuSE/inst_source/10.1)
1: [x] file:/iscsi/Archives/SuSE/inst_source/10.1_up/ (file:/iscsi/Archives/SuSE/inst_source/10.1_up) [autorefresh]
debug disabled
90 packages to install
unresolvable dependencies:
*** Conflicts ***
Name: /bin/sh(*)
Edition: EDITION-UNSPEC
Referers: aaa_base-10.1-41 requires /bin/sh,

Not-Available: any

Name: /bin/bash(*)
Edition: EDITION-UNSPEC
Referers: aaa_base-10.1-41 requires /bin/bash, bind-utils-9.3.2-17 requires /bin/bash, groff-1.18.1.1-29 requires /bin/bash, less-394-12 requires /bin/bash, module-init-tools-3.
2.2-32.13 requires /bin/bash, perl-5.8.8-12 requires /bin/bash, pwdutils-3.0.7.1-17 requires /bin/bash, rpm-4.4.2-43.4 requires /bin/bash, util-linux-2.12r-35 requires /bin/bash
Not-Available: any

Ideas please....

--

Anders Norrbring
Norrbring Consulting
< Previous Next >
Follow Ups