Mailinglist Archive: opensuse-packaging (70 mails)

< Previous Next >
FYI: Unresolveable dependencies
  • From: Andreas Schneider <mail@xxxxxxxxxxxx>
  • Date: Sat, 13 May 2006 16:30:40 +0200
  • Message-id: <4465ED90.60004@xxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I've downloaded the 10.1 tree to compile my Packman packages for 10.1. The
problem is there are really strange errors with y2pmbuild. It's a problem with
the old packagemanager and rpm package alternatives.

BuildRequires: kdebase3-devel

unresolvable dependencies:
*** Conflicts ***
Name: avahi-compat-mDNSResponder
Edition: 0.6.5-27
Referers: kdelibs3-3.5.1-47 requires libdns_sd.so()(64bit), kdelibs3-3.5.1-47
requires libdns_sd.so()(64bit)
Conflicts-With: mDNSResponder-lib-107.5-8 conflicts with
avahi-compat-mDNSResponder, mDNSResponder-lib-107.5-8 conflicts with
avahi-compat-mDNSResponder, avahi-compat-mDNSResponder-0.6.5-27 conflicts with
mDNSResponder-lib, avahi-compat-mDNSResponder-0.6.5-27 conflicts with
mDNSResponder-lib
Remove-To-Solve-Conflict: kdebase3-devel, kdelibs3-devel, mDNSResponder-devel,
mDNSResponder-lib


mDNSResponder-lib and avahi-compat-mDNSResponder provide libdns_sd.so, so you
need as BuildRequires

BuildRequires: mDNSResponder-lib kdebase3-devel


-- andreas

- --
http://www.cynapses.org/ - cybernetic synapses

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iD8DBQFEZe2Qf94+j/M+P8YRAqJMAJ0dOA7pmA+k+gorpfNEl+tLkkPIAwCfSVLd
KeUzSPKUAYL/SA/3n1LSS+Y=
=8iQy
-----END PGP SIGNATURE-----

< Previous Next >
Follow Ups