Mailinglist Archive: opensuse-multimedia-de (261 mails)

< Previous Next >
Re: [suse-multimedia] Suse 9.2 und Hauppauge WinTV PVR firmware uplad
  • From: Maik Holtkamp <s-y-l@xxxxxxx>
  • Date: Wed, 16 Feb 2005 00:10:42 +0100
  • Message-id: <20050215231040.GD2248@xxxxxxxxxxxxxxxxx>
Hi,

0n 05/02/15@15:27 Klaus Gieb told me:

> ich habe eine Hauppauge WinTV PVR karte.
>
> seit dem update von 9.0 auf 9.2 (und damit auf den 2.6er kernel) funktioniert
> der ton nicht mehr, da die firmware nicht mehr hochgeladen wird (ganz sicher
> kein problem mit soundkarte).
> früher (2.4.x) wurde diese, vom bttv modul, direkt aus
> /usr/lib/video4linux/hcwamc.rbf geladen.
>
> meinem verständis nach, ist neuerdings (2.6.x) hotplug für dieses laden
> verantwortlich. aus irgend einem grund geht dies aber nicht.
>
> die firmware liegt in /usr/lib/hotplug/firmware/hcwamc.rbf
>
> meiner meinung nach, sollte dies genügen, um die firmware zu laden.
> der treiber sagt aber in der /var/log/messages:
> bttv0: no altera firmware [via hotplug]
> d.h. der aufruf:
> rc = request_firmware(&fw_entry, "hcwamc.rbf", &btv->c.pci->dev);
> im treiber (bttv-cards.c) geht schief.
>
> seltsamer weise scheint hotplug aber gar nicht 'gefragt' zu werden:
> habe in '/etc/sysconfig/hotplug' HOTPLUG_DEBUG="max" gesetzt.
> zum zeitpunkt des modul ladens (also nach 'modprobe bttv') kommen aber
> keinerlei meldungen von hotplug.
>
> habe ich etwas übersehen/vergessen?
> mache ich etwas grundlegend verkehrt?

Ich kenne die PVR 350 nicht, aber AFAIK wird die vom bttv nicht
unterstuetzt sondern braucht IvyTV. Auf die Schnelle habe ich das
hier gefunden:

http://marc.waeckerlin.org/linux/pvr.php

aber IIRC gibt es auch in der mythtv Doku weitere Infos.

--
bye maik
< Previous Next >
Follow Ups
References