Mailinglist Archive: opensuse-multimedia-de (389 mails)

< Previous Next >
Re: [suse-multimedia] relocation error bei noteedit
  • From: Manfred Tremmel <Manfred.Tremmel@xxxxxx>
  • Date: Fri, 13 Dec 2002 12:49:40 +0100
  • Message-id: <200212131249.40651.Manfred.Tremmel@xxxxxx>
Am Freitag, 13. Dezember 2002 02:56 schrieb Sven Rodenbeck:

> > mount /media/dvd
> > su
> > <Passwort>
> > cd /media/dvd/suse/i586
> > ls *wasichauchimmersuche*
> > rpm -Uvh wasichauchimmergefundenhab.rpm
> > exit
> > umount /media/dvd
>
> Ist ein toller Tip! Auf die einfachsten Sachen kommt manchmal nicht
> selbst.

Und nicht die ARCHIVES.gz im Basisverzeichnis der DVD/CD vergessen. Wenn
Du bei installation eines RPM's ne Meldung kriegst, die Bibliothek xyz
fehlt, einfach mit 'zgrep xyz ARCHIVES.gz' suchen und (falls das Ding
auf der SuSE DVD/CD ist) schon kriegst Du das passende RPM angezeigt.

In SuSE 7.3 ging das im "alten" yast ja noch relativ komfortabel über
die Paketauskunft, seit er abgesägt wurde (RIP), muß man halt ein
bisserl improvisieren.

> Jetzt zum Eigentlichen:
> > Ich glaub nicht, dass das was ändert. Hab mir mal das strace
> > logfile angesehen und auch mit einem hier bei mir verglichen. Ich
> > würd fast wetten, das es an alsa liegt.
>
> Treffer!! Hurra!!
> Sogar die deutsche Hilfe ist dabei!! :-))

Na also ;-)

> Das Blöde ist, ich hab das ja auch versucht, nur habe ich den Fehler
> gemacht, zwischen "no" und "alsa" ein Leerzeichen zu setzen (oder
> hatte ich nur ein Minus gesetzt?)
>
> Es funktioniert also mit:
> noteedit --noalsa
> noteedit --nooss

Fein.

> Zum Schluß noch die Frage: Du bietest bei packman die alsa-tools und
> ein alsa-Update.

Ja. Zum einen weil ich hier auf Kernel 2.4.20 updated habe und dann
gleich die neusten alsa-driver 0.9rc6 mit raufgeklatscht hab und eben
auch die passenden libs haben wollte (aber keine Angst, funktioniert
auch ohne jegliche Problem mit dem SuSE Kernel und mitgelieferten
alsa-treibern, habs ausprobiert). Und zum anderen, weil ich mit den
"alten" von SuSE ein kleines Problemchen hatte. Wärend KMidi die
Midifähigkeiten meiner Soundkarte in den eigenen Einstellungen ohne
Probleme erkannt hat, war im KDE-Knotrollzentrum nichts davon zu sehen.
Wird KMidi nun im Konqueror eingebettet gestartet, bedient es sich aber
der Einstellungen im KDE-Kontrollzentrum und ich krieg nur ne
Fehlermeldung...

> Ich hab' die SuSE 8.1 ja unter anderem deswegen gekauft, weil ich
> dachte: "onboard-sound wird unterstützt"
> läuft auch nicht anders als bei 7.3/8.0 bei mir.

Na gut, Unterstützt wird sie, sobald Du irgend ein Quäcken aus dem
Lautsprecher kriegst. Hardwareseitig hat ein OnBoard-Sound auch mit
Sicherheit keine MIDI-Unterstützung, so dass dies Windowsseitig (falls
da unterstützt) auch reine Softwarearbeit ist, analog timidity unter
Linux, nur eben noch besser integriert.

> Was sollte ich jetzt noch installieren (oder timidity nutzen?) um
> meine VT8233 AC 97 mit noteedit in "Einklang" zu bringen?

Hast Du Dir das entsprechende Kapittel im Handbuch schon mal angeschaut.
Da ist einiges zur Integration von timidity drin.

Du kannst auch mal Versuchen 'noteedit --arts' zu starten, vielleicht
integriert der das schon.

> Oder sollte ich doch eine "echte" Soundkarte kaufen? Brauche
> eigentlich nur die Hörkontrolle, erwarte von einem Rechner natürlich
> nicht den Sound meiner Stereo-Anlage.

Mußt Du wissen, wie viel Zeit Dir das rumexperimentieren noch Wert ist
und wie wichtig die Hörprobe erscheint. Vergleichsweise günstig (< 40
Euro) gibts im Augenblick die Soundblaster Live! Player 5.1, die
problemlos läuft und wirklich komplett von Linux unterstützt wird, von
MIDI (in SuSE 8.1 wird das automatisch konfiguriert, Soundfonts werden
von der Original-Treiber CD nachinstalliert und es läuft) bis Surround
Sound (z.B. mit xine beim DVD-Schaun).

> Einen vituellen Kaffe (Tee, Whisky ,Bier ,was immer Du magst) von
>
> Sven

Wers geniesen ;-)

--
Machs gut | http://www.iivs.de/schwinde/buerger/tremmel/
| http://packman.links2linux.de/
Manfred | http://www.knightsoft-net.de


< Previous Next >
Follow Ups