Mailinglist Archive: opensuse-mobile-de (91 mails)

< Previous Next >
pcmcia-netzwerkkarten
  • From: "Daniel Straessle" <daniel.straessle@xxxxxxxxxxxx>
  • Date: Wed, 26 Sep 2001 14:25:21 +0200
  • Message-id: <3BB1C931.1BE4AAC0@xxxxxxxxxxxx>
Hi,

ich wollte meinen aelteren Laptop als Router verwenden und hab mir 2
xircom Netzwerkkarten organisiert. Mit der einen wollte ich die
Verbindung ins Internet (Cablemodem) und mit der anderen die Verbindung
ins LAN sicherstellen.

Jetzt hab ich das Problem, dass ich mit meinem SuSE7.2 jeweils nur 1
Netzwerkkarte verwenden kann.
Wenn ich mit 'cardctl status' nachschaue kommt:

Socket 0:
5V 16-bit PC Card
function 0: [ready]
Socket 1:
5V 16-bit PC Card
function 0: [ready]

Beim Booten erscheint folgende Meldung:

xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
eth0: Xircom: port 0x300, irq 3, hwaddr 00:10:A4:A4:AF:95
eth0: MII link partner: 0021
eth0: MII selected
eth0: media 10BaseT, silicon revision 4
eth1: Xircom: port 0x310, irq 5, hwaddr 00:80:C7:B5:BC:B7
eth1: media 10BaseT, silicon revision 4
eth1: media 10BaseT, silicon revision 4

beim 'cardctl ident' kommt:
Socket 0:
product info: "Xircom", "CreditCard 10/100", "CE3-10/100", "1.00"
manfid: 0x0105, 0x010a
function: 6 (network)
Socket 1:
product info: "Xircom", "CreditCard 10/100", "CE3-10/100", "1.00"
manfid: 0x0105, 0x010a
function: 6 (network)


Bei einen 'lsmod' erscheint:
Module Size Used by
xirc2ps_cs 11936 2
unix 16832 12

Ich hab die erste Karte als dhclient und die zweite als 'feste ip
(192.168.0.99)' installiert. Beides laeuft, allerdings eben nur entweder
oder. Bei ifconfig erscheint:

eth0 Link encap:Ethernet HWaddr 00:10:A4:A4:AF:95
inet addr:217.162.107.189 Bcast:255.255.255.255
Mask:255.255.254.0
UP BROADCAST NOTRAILERS RUNNING MTU:1500 Metric:1
RX packets:30456 errors:0 dropped:0 overruns:0 frame:0
TX packets:15426 errors:0 dropped:0 overruns:0 carrier:8
collisions:0 txqueuelen:100
RX bytes:2736441 (2.6 Mb) TX bytes:3169346 (3.0 Mb)
Interrupt:3 Base address:0x300

eth1 Link encap:Ethernet HWaddr 00:80:C7:B5:BC:B7
inet addr:192.168.0.99 Bcast:192.168.0.255
Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:5 Base address:0x310

hier geht eth0, aber aufs LAN (eth1) komme ich nicht

meine Route:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth1
217.162.106.0 * 255.255.254.0 U 0 0 0 eth0
default cbl.ubrUzNord1. 0.0.0.0 UG 0 0 0 eth0

ein arp -a gibt :

? (192.168.0.80) at <incomplete> on eth1

wobei ein arp -a auf dem client (192.168.0.80) eine vollstaendige
Auskunft mit physicalAddress ausgibt.

Habe Kernel 2.4.9pre14 und 1.4.10 versucht und cs-pcmcia-3.1.29 - ging
alles nicht. Kann mir jemand weiterhelfen ? Bin fuer jeden Hinweis
dankbar


thx Daniel



< Previous Next >