Mailinglist Archive: opensuse-marketing (156 mails)

< Previous Next >
[opensuse-marketing] Lilypond won't work with guile 2.0, What can I do to prevent it being dropped? Do we really want guile 2.0 yet?
OpenSUSE has jumped way ahead of all the other major distributions by pushing guile-2.0 to factory, this may cause problems for packages such as gnucash if it uses guile to the extent that lilypond does. Lilypond uses guile extensively and are working on porting lily to guile 2.0 but this is their timeline quoted from one of my emails from Graham Percival to the devel list please note that lilypond 2.16.0 may not be released before openSUSE 12.1 and I'm working on 2.14.2 atm the current release :

There is absolutely zero chance of lilypond 2.16 using guile 2.0.
There is maybe a 10% chance that any version of lilypond will
support guile 2.0 in 2011. Total guesswork for future
predictions: 50% chance of supporting guile 2.0 before July 2012,
80% chance of support guile 2.0 before the end of 2012.

What that means for opensuse is up to you. If you particularly
want guile 2.0, then by all means jump in; the more people working
on it, the higher the chances are that it'll get done sooner. But
based on the amount of work that currently goes into guile 2.0,
those are my estimates.

Cheers,
- Graham

and I think this is also relevant, another lily developers reply from the same
message:

Given that the upcoming ubuntu oneiric apparently does not include guile 2.0, I
also don't see a switch to guile 2.0 in the near future.
I suppose that we should ask the ubuntu people when they'll finally package
guile 2.0.

Cheers,
Reinhold

I've looked at parallel installation of guile 1.8.8 (we jumped from 1.8.7 to 2.0.1) and it doesn't look easy otherwise I would have submitted guile1 but I'm still working on it although I'm not that familiar with the autoconf/automake build system at this level.

What this means for openSUSE, lilypond is a very popular musical notation type setting program, the developers pride themselves in the accuracy of the notation positions, it is also used, for musical notation by rosegarden, a popular music and midi composition program. Both of these applications have no substitutes in the open source world and only have costly equivalents in the ms windows world, neither being available for ms windows although there are requests to port for both this won't happen in the immediate future. Rosegarden can work without lilypond as it is only bound to lilyponds notation fonts but the sheet music it exports will be useless so it will lose major functionality.
Lilypond won't even be able to be installed via tarball on openSUSE 12.1 without the user removing guile 2.0 completely and installing guile 1.8 via tarball, as a result these users of lilypond and rosegarden will drop openSUSE.

I started as a community maintainer by saving both lilypond and rosegarden from being dropped, I'm now very active in maintaining multimedia apps and libs and losing these programs will mean losing a large section of professionals in music related professions that have migrated from the windows world including the people that I've converted from ms windows just by showing them rosegarden although ms's change from xp to vista also helped.

For the other packages that directly depend on guile : guile aisleriot gnucash autogen and slib, the change back to guile-1.8.8 won't AFAICS have any negative effects, all of these packages simply have patches for guile 2.0 and after looking at the patches, will most probably build with the patches still in place. I don't know what the situation is with guile users but it is an app for use by apps and not a direct users app. Guile-1.8.7 builds for factory, guile-1.8.7 doesn't build for 11.4.

What are we going to do? Drop lilypond, I will keep it alive in home:plater:lilypond with guile-1.8.8 to replace guile-2.0.2 or revert to guile-1.8.8 in line with the other linux distributions?

Thanks
Dave Plater

--
To unsubscribe, e-mail: opensuse-marketing+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-marketing+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups