Mailinglist Archive: opensuse-m17n (27 mails)

< Previous Next >
Re: [opensuse-m17n] IM-related issues on openSUSE 12.1 Beta
At Wed, 12 Oct 2011 01:12:28 +0900,
Fuminobu TAKEYAMA wrote:

> The updated (and fixed) package is found in OBS
> home:tiwai:branches:M17N/scim repo.
>
> As API/ABI is kept compatible, it's better to upgrade SCIM for 12.1,
> unless anyone has a strong objection.

It works fine on 12.1 b1.
And I prepared scim-bridge-0.4.15.

Since 11.4 users can try these updated packages,
I think they should be pushed to M17N soon.

OK, scim is submitted & accepted in M17N now.
Please update scim-bridge, too.

The fix for missing GTK3 support can be submitted later in addition.

Maybe we should create bugzilla entries for scim bugs, to track and
record in changelog properly. I'm going to open an scim bug for
Firefox now. If any other bugs are missing, feel free to create
reports.


thanks,

Takashi

Fuminobu TAKEYAMA

(2011/10/11 21:10), Takashi Iwai wrote:
At Mon, 10 Oct 2011 19:54:41 +0200,
Takashi Iwai wrote:

At Tue, 11 Oct 2011 02:34:04 +0900,
Fuminobu TAKEYAMA wrote:

However, if I set "GTK_IM_MODULE=scim",
firefox outputs errors that are similar to:
https://bugzilla.novell.com/show_bug.cgi?id=680430

Does GTK_IM_MODULE=scim work at all? I doubt that the problem remains
from 11.4 unfixed, but no one didn't care (and experience) because
usually scim-bridge is used instead. Maybe upgrading scim to the
latest version fixes the issue?

I tried the latest version scim-1.4.11, and it shows the same
problem. A similar fix like scim-bridge makes working it again with
Firefox. The updated (and fixed) package is found in OBS
home:tiwai:branches:M17N/scim repo.

As API/ABI is kept compatible, it's better to upgrade SCIM for 12.1,
unless anyone has a strong objection.


thanks,

Takashi

--
To unsubscribe, e-mail: opensuse-m17n+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-m17n+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups