Mailinglist Archive: opensuse-kernel (76 mails)

< Previous Next >
Re: [opensuse-kernel] kernel package versioning
At Tue, 14 Jun 2011 11:09:01 -0400,
Jeff Mahoney wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 06/14/2011 04:29 AM, Michal Marek wrote:
On 13.6.2011 18:44, Bruno Friedmann wrote:
I'm just afraid about how much factory tester will forget to upgrade
3.0.rc2 to 3.0.[0-9] as zypper/rpm/solver will always
consider it a downgrade version.

As I wrote, rpm sorts letters before numbers, so unlike strcmp(), we
have "rc2" < "0":

$ zypper vcmp 3.0.rc2 3.0.0
3.0.rc2 is older than 3.0.0

So it should all work fine.

Isn't this a relatively recent change, though? I seem to recall that we
couldn't do the .rc2 naming when we first started releasing RPMs with RC
kernels specifically because they'd be evaluated after the numeric
versions and would break updates.

It's not that new. SLE10 should work like that, IIRC.

The point of the new scheme looks like that it doesn't append the rc,
but it's a replacement of the last 0. That is, if we used a version
like 2.6.39.0, an rc version like 2.6.39.rc3 should have worked well.


Takashi
--
To unsubscribe, e-mail: opensuse-kernel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-kernel+help@xxxxxxxxxxxx

< Previous Next >