Mailinglist Archive: opensuse-kde3 (24 mails)

< Previous Next >
Re: [opensuse-kde3] 11.4 note - Trinity will not build with gcc >= 4.5
On Mon, Feb 14, 2011 at 18:26, Robert Xu <robxu9@xxxxxxxxx> wrote:
On Mon, Feb 14, 2011 at 17:58, Ilya Chernykh <neptunia@xxxxxxx> wrote:
On Tuesday 15 February 2011 01:10:06 Robert Xu wrote:

 The Trinity source will not build with gcc >= 4.5. See:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=47723

 The open question is whether it is gcc or Trinity that needs to be
fixed. I don't know which gcc 11.4 will use, but keep this in mind if it
has 4.5 or later.

We're looking into it, don't worry. It may be a cmake generation
error, calm down.

KDE3 in KDE:KDE3 builds well with GCC 4.5. Thus I think we should not upgrade
to Trinity right now.


Ok - This is a cmake error, DON'T PANIC. Everything builds well with GCC 4.5.


Commence damage control.
New revision in SVN fixes this problem, as well as the cmake generation.

And yes, it always built with gcc 4.5, and we're going to get it
working with 4.6 when it comes out.

For working examples on MDV 2010.1, openSUSE 11.3 and openSUSE
Factory, and Fedora 14, wait until Wednesday.

End damage control.


--
later, Robert Xu
--
To unsubscribe, e-mail: opensuse-kde3+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-kde3+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups