Mailinglist Archive: opensuse-kde (206 mails)

< Previous Next >
Re: [opensuse-kde] File conflict between kdelibs3 and kdelibs4
On Wed, Mar 28, 2012 at 05:04:18PM +0200, Petr Mladek wrote:
Greg KH píše v St 28. 03. 2012 v 07:38 -0700:
On Wed, Mar 28, 2012 at 03:35:58PM +0200, Andreas Jaeger wrote:
Building of LibreOffice fails with:

installing kdelibs4-4.8.1-2.1
file /usr/share/man/man1/checkXML.1.gz from install of
kdelibs4-4.8.1-2.1.x86_64 conflicts with file from package
kdelibs3-3.5.10-58.1.x86_64
exit ...

This file conflict needs to be resolved, could you find a solution,
please?

Btw. I wonder why LibreOffice needs both kdelibs - still the
conflicts needs to be resolved,

We need support for KDE4 because it is default on openSUSE. I removed
KDE3 support in the past but KDE3 users wanted it back. So, I accepted
submit request from Ilya and added it back. Thus we need both KDE3 and
KDE4 during build.

The conflict is an evident bug in KDE3/KDE4. It must cause problems also
in other circumstances. This is why ignored it for few days. I am busy
with LO-3.5 releases and packaging.


Please see:
https://bugzilla.novell.com/show_bug.cgi?id=754146

I am sorry, I am very overloaded these days and I am late in reading
mails and bugzilla.

No problem, I'd rather see 3.5 packages instead anyway, as long as it
doesn't have the same KDE3/KDE4 build issue :)

greg k-h
--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde+owner@xxxxxxxxxxxx

< Previous Next >