Mailinglist Archive: opensuse-kde (176 mails)

< Previous Next >
Re: [opensuse-kde] %kde4_pimlibs_requires not recognised in Mandriva_2010.1
  • From: David Jarvie <lists@xxxxxxxxxxxxxxx>
  • Date: Tue, 12 Oct 2010 23:50:43 +0100
  • Message-id: <201010122350.43631.lists@xxxxxxxxxxxxxxx>
On Monday 11 October 2010 18:18:49 Lubos Lunak wrote:
On Wednesday 06 of October 2010, David Jarvie wrote:
My spec file has the line

%kde4_pimlibs_requires

This has worked up to now for Mandriva, openSUSE and Fedora, but building
for the Mandriva_2010.1 repository produces this error:

error: line 29: Unknown tag: %kde4_pimlibs_requires

Does this macro need to be updated?

I assume this is with the obs-generator tool? Then the answer is no. You
cannot use the tool's unified spec format and then simply add a random
unprepared repo and hope it'll work there too. I've added support for
Mandriva2010.1, use --setup-project-unified with the tool to update the build
repositories to all currently supported ones.


I tried running the command in the project's osc directory, but got an error:

$ kde-obs-generator --setup-project-unified home:djar:kalarm
Server returned an error: HTTP Error 400: Bad Request
repository Mandriva_2010.1 listed more than once
ERROR: Cannot update project configuration
Aborted

I then moved all project files except the tarball out of the directory, and the
command ran without error (or any other type of feedback). However, the
Mandriva_2010.1 target is still flagged as unresolvable - reason = "nothing
provides libkdepim4-devel".

--
David Jarvie.
KAlarm author and maintainer.
http://www.astrojar.org.uk/kalarm
--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-kde+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups