Mailinglist Archive: opensuse-kde (237 mails)

< Previous Next >
Re: [opensuse-kde] [IMPORTANT] Qt 4.5.0 will enter KDE:Qt
  • From: Alvin <alvinbeach@xxxxxxxxx>
  • Date: Sat, 7 Feb 2009 13:22:15 -0400
  • Message-id: <200902071322.17022.alvinbeach@xxxxxxxxx>
On Friday 06 February 2009 17:27:36 Herbert Graeber wrote:
Am Freitag 06 Februar 2009 15:25:37 schrieb Malte Gell:
Am Donnerstag, 5. Februar 2009 16:51:41 schrieb Dirk Müller:
Hi,

We're currently moving the latest stable Qt 4.4.x from KDE:Qt to
KDE:Qt44. This version will also be released as an online update to
openSUSE 11.1, which removes the need for having KDE:Qt enabled for
most openSUSE 11.1 users.

KDE:Qt will switch to Qt 4.5.0 (currently rc1) by next week.

Oh, one more question, will KDE 4.2 at any time become a stable tree for
openSUSE 11.1 or will it stay in KDE:factory?

KDE:KDE4:Factory will switch the KDE 4.3, once it enters openSUSE:Factory.

I have asked on IRC if it is possible to save the latest state of KDE 4.2
in an additional repository. Stephan Binner answered that he can copy it to
KDE:KDE4:KDE42. So it looks like we can stay on KDE4.2, until we feel KDE
4.3 is stable enough.

Herbert

IMHO, this is a good idea. I'm not sure why there is UNSTABLE, STABLE and
Factory at all for something as specific as KDE? Perhaps the KDE repo should
just be named as it is versioned (just like openSUSE distro repo - e.g.
openSUSE_11.1) as in KDE41, KDE42, and eventually KDE43. This will remove all
the confusion. Once a version becomes obsolete, simply remove the repo. Then
those that have the repo configured in Yast or Smart will get an error. Then
they will know that they will need to update their repo list rather than
being surprised when a new major version is installed (especially those that
don't monitor this mailing list). For the supported version, a symlink
like "current" could be setup so that those that want to stick with the
version that came with the distro wont have to worry about changing the repo
to keep the current stable version.

I know this has been discussed before in this ML, but I haven't been following
the subject too closesly. I've been just trying to make sure that I have the
right repos. :)

Alvin


--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-kde+help@xxxxxxxxxxxx

< Previous Next >