Mailinglist Archive: opensuse-kde (287 mails)

< Previous Next >
Konqueror SIGABRT on startup
  • From: Colin Pinkney <suse-kde@xxxxxxxxxxxxxxx>
  • Date: Sat, 28 Aug 2004 16:29:14 +0100
  • Message-id: <200408281629.14917.suse-kde@xxxxxxxxxxxxxxx>
I've got SuSE 9.0 Pro and I just upgraded to the latest KDE 3.3 packages from
the SuSE supplementary feed using YAST. I've done this loads before and
everything has been fine.

Now however, konqueror has started to abort (SIGABRT) when I start it up with
the web profile. With the file browsing profile it is fine and the preloaded
instance also starts ok.

The part where it goes wrong is when its preloading some kparts:

konqueror: kparts/factory.cpp:79: virtual QObject*
KParts::Factory::createObject(QObject*, const char*, const char*, const
QStringList&): Assertion `!parent ||parent->isWidgetType()' failed.

I've tried redownloading and reinstalling kdelibs, kdebase and any other kde
packages that I could find which contain kparts or konqueror stuff. I've also
reinstalled QT just in case something got corrupted, but it hasn't fixed it.

The error seems to be pretty low level to me, yet I cannot find any other KDE
app that is affected like this. Even Quanta and its web preview work fine and
I cannot find anything at bugs.kde.org.

Has anyone else seen this? Thanks

--
Colin Pinkney
http://www.cpinkney.org.uk

< Previous Next >