Mailinglist Archive: opensuse-kde (287 mails)

< Previous Next >
Re: [suse-kde] openoffice problem with kde3.3
  • From: Michael Riess <riessmi@xxxxxx>
  • Date: Sun, 29 Aug 2004 23:54:11 +0200
  • Message-id: <41325083.90004@xxxxxx>
Frank Fabian schrieb:
Hello Dave,

Am Thu, 26 Aug 2004 14:59:53 +1200
schrieben Sie (Dave O'Reilly <dave.oreilly@xxxxxxxxxxxxxx>):


HI all,
I upgraded my SuSE 9.1 box to KDE 3.3 via yast by adding ftp://ftp.suse.com/pub/suse/i386/supplementary/KDE/update_for_9.1/yast-source

to my list of installation sources and updating all KDE packages. I
have one problem now...openoffice won't start. I get the following:

daveor@jimbo:~> OOo-writer
Starting /opt/OpenOffice.org/program/swriter...
soffice.bin: kdecore/kcmdlineargs.cpp:159: static void
KCmdLineArgs::init(int, char**, const KAboutData*, bool): Assertion
`argsList == 0' failed. Aborted
daveor@jimbo:~>


anyone seen this or know what it's about?


nobody brought it up, so I'll give you a workaround that Manfred Tremmel
mentioned on the suse-linux (German) list:

You have to edit file /usr/X11R6/bin/OOo-template. In line 1339

test "${WINDOWMANAGER:0-3}" = "kde" && OOo_WIDGETS_SET=kde

put a "#" (comment sign) at the beginning of the line, and everything
should work again. This affects the look of OOo, it doesn't use the KDE
style anymore, but it works.

I played a bit with the Script:

it is only the line
export OOo_WIDGETS_LIBRARY_PATH="$OOo_GLOBAL_HOME/program/widgets/kde"
which has to be commented out

seems to me that the
kde widget lib
in this OOo_WIDGETS_LIBRARY_PATH
from OOo doesnt work anymore with KDE3.3

on the other side it comes up
with the KDE-style anyway on my machine
but i dont know what lib it uses instead of

< Previous Next >
Follow Ups