Mailinglist Archive: opensuse-kde (241 mails)

< Previous Next >
Installing KDE 3.1 from new RPM's
  • From: Peter Nunn <pnunn@xxxxxxxxxxxxxxx>
  • Date: Wed, 29 Jan 2003 21:54:49 +1100
  • Message-id: <200301292154.49182.pnunn@xxxxxxxxxxxxxxx>
Hi folks,

I just downloaded all the rpm's from Suse 8.1 and tried to install following
the directions in the ftp directory.

During the install I got a few could not install messages so did a --force
(as I did on another system using 8.0 with one of the beta 3.1's).

It now seems that there is a corrupt rpm on the mirrors.

when I try and do rpm -Fvh qt3-3.1.1-15.i586.rpm I get

qt3 ######unpacking of archive failed on file
/usr/lib/qt-3.1.1/lib/libqt-mt.so.3.qt3
1.1: cpio: read

now, when I startx, it failes (funny that I guess) with

(==) Using config file: "/etc/X11/XF86Config"
ioctl FBIOPAN_DISPLAY: Invalid argument
Symbol shadowAdd from module /usr/X11R6/lib/modules/drivers/fbdev_drv.o is
unresolved!
Symbol shadowUpdateRotatePacked from module
/usr/X11R6/lib/modules/drivers/fbdev_drv.o is unresolved!
Symbol shadowSetup from module /usr/X11R6/lib/modules/drivers/fbdev_drv.o is
unresolved!
ksplash: relocation error: /opt/kde3/lib/libDCOP.so.4: undefined symbol:
static_QUType_varptr
....
startkde:Could not start kdeinit. Check your installation.
Warning: connect() failed: : No such file or directory
....

Any ideas what I can do to recover this situation?

Thanks.

Peter.

< Previous Next >
Follow Ups