Mailinglist Archive: opensuse-ja (35 mails)

< Previous Next >
Re: [suse-linux-ja] 32-bit MPlayerをb uildしたい
  • From: Satoru Matsumoto <helios_reds@xxxxxxx>
  • Date: Sun, 16 Jul 2006 00:25:56 +0900
  • Message-id: <44B90904.4070109@xxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

こんばんわ、松本です。

野宮 賢 / NOMIYA Masaru wrote:

> Emacs上で使うアプリの関係で,32-bit MPlayer をビルドする必要性に迫られてい
> ます.因に,SuSE 10.0 を Dual Opteronシステムで使用しています.

Packmanの MPlayer-1.0pre8-4.i586.rpm
http://packman.links2linux.de/index.php4?action=128&vn=3
ではダメなんでしょうか? というのはさておき…

> /usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /opt/gnome/lib64/libgtk-x11-2.0.so when searching for -lgtk-x11-2.0
> /usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /opt/gnome/lib64/libgtk-x11-2.0.so when searching for -lgtk-x11-2.0
> /usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin/ld: cannot find -lgtk-x11-2.0
> collect2: ld returned 1 exit status
> make: *** [mplayer] エラー 1
>
> と Abend します.
> このエラー・メッセージは.gtk-x11-2.0.so が無い,と言っていると思われるので
> すが,
>
> lrwxrwxrwx 1 root root 25 2006-06-23 17:03 /opt/gnome/lib64/libgtk-x11-2.0.so -> libgtk-x11-2.0.so.0.800.3
>
> とちゃんとあります.... (_ _?

gtk2-32bitパッケージは入れてありますか?

手元のSUSE 10.1で見てみると、

$ file /opt/gnome/lib/libgtk-x11-2.0.so.0
/opt/gnome/lib/libgtk-x11-2.0.so.0: symbolic link to
`libgtk-x11-2.0.so.0.800.10'
$ rpm -qf /opt/gnome/lib/libgtk-x11-2.0.so.0.800.10
gtk2-32bit-2.8.10-36

…ということになっています。もしかしたら32bit版をビルドする時は、
/opt/gnome/lib64ではなく、/opt/gnome/libを見にいっているのではないか、な
どと推測しているんですが、どうでしょう?

MPlayerをビルドしたわけではないから当てずっぽうですけれど…。

- --
□●□ _/_/_/ To be Happy! _/_/_/
□□● _/_/ Satoru Matsumoto _/_/
●●● _/ helios_reds@xxxxxxx _/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iD8DBQFEuQkDXnHIfHE6+z0RAsekAKCOny8HTeTgRrO6mWNVy9IntMAVNgCgi2HT
K4TvFU2f0DmktFCkHhUgtEw=
=00I7
-----END PGP SIGNATURE-----

< Previous Next >