Mailinglist Archive: opensuse-isdn-de (249 mails)

< Previous Next >
AVM capi4linux unter SuSE 7.1 - so gehts!
  • From: "Julian Pawlowski" <lists@xxxxxxxxxxxxxx>
  • Date: Thu, 15 Feb 2001 09:16:14 +0000 (UTC)
  • Message-id: <DGEEIJPMADFAHFNHEOGNMEPICCAA.lists>
Hallo zusammen!

Nach etlichem Herumbesteln und Suchen im Netz habe ich es nun
geschafft, die AVM Capi unter SuSE Linux 7.1 mit Kernel 2.4.0-4GB auch
zusammen mit i4l zum Laufen zu bekommen.

Hier einmal der Werdegang für Interessierte:

1.) Man lade sich das neue TarGZ von meinem FTP:

ftp://ftp.thepenguin.de/linux/capi4linux/fcpci-suse7.1-03.09.02.tar.gz

2.) Man editiere /usr/src/linux-2.4.0.SuSE/include/linux/version.h
und ändere dort die Versionsnummer von "2.4.0" auf "2.4.0-4GB".
Ich weiss nicht genau, ob das nötig ist. Jedoch hatte ich sonst
Probleme
beim Kompilieren. SuSE hat den Kernel wohl so genannt - nur nicht
in den
installierten Sourcen, was dann doch oft zu Fehlern führt (bei mir
jedenfalls).

3.) Die geladene Datei in ein leeres Verzeichnis entpacken:
tar xfz fcpci-suse7.1-03.09.02.tar.gz

4.) In das Verzeichnis "fritz" wechseln:
cd fritz/
und dort das angepasste Install-Script aufrufen:
./install

Bitte wirklich in das Verzeichnis wechseln, da sonst einige
Abhängigkeiten nicht mehr stimmen es es zu einem Fehler beim Ausführen
des Scriptes kommt.
Falls i4l gefunden wurde, wird das init-Script
/etc/init.d/i4l_hardware ausgetauscht. Dieses ist bereits an die LSB
konformen init-Scripte angepasst und funktioniert auch wirklich mit
i4l zusammen (was man von dem AVM-Script ja nicht sagen kann...). Wird
i4l nicht gefunden, so wird das CAPI-Startscript "c4l_start" nach
/etc/init.d kopiert und mittels LSB in die Startscript-Struktur
eingebunden.
Danach werden die beigepackten CAPI-Tools automatisch neu kompiliert
und installiert. Sollte hierbei ein Fehler auftreten, so ist in der
Log-Datei "install.log" nachzuschauen. Zu guter Letzt wird noch der
eigentliche Treiber fcpci.o kopiert (ist bereits kompiliert). Bei
installiertem i4l stellt man jetzt noch mit YaST auf "AVM B1 PCI" als
ISDN-Karte um. Nach einem Neustart sollte alles wie gewohnt
funktionieren. Alternativ kann man auch eingeben:

- rci4l stop
- rci4l_hardware restart
- rci4l start

Das wars.

Ich übernehme natürlich keinerlei Garantie dafür, dass das alles so
funktioniert. Außerdem sollte man beachten, dass es sich bei dem
geladenen Packet _nicht_ um ein offizielles Realise der Firma AVM
handelt! (sieh auch beigefügt README-Datei).


Ciao

Julian

--
______
JP solution Internet Services / \
D-31655 Stadthagen, Germany / /___/
Visit: www.JP-solution.de \__/



< Previous Next >
This Thread
  • No further messages