Mailinglist Archive: opensuse-fr (42 mails)

< Previous Next >
Re: [opensuse-fr] compilation mailertable sendmail
  • From: "nikopol@xxxxxxx" <nikopol@xxxxxxx>
  • Date: Sun, 5 Jul 2009 17:42:58 +0200
  • Message-id: <200907051742.58450.nikopol@xxxxxxx>
Le Sunday 05 July 2009 10:17:06 Laurent HENRY (EHESS/CRI), vous avez écrit :
Le Sam 4 juillet 2009 20:01, nikopol@xxxxxxx a écrit :
Le Saturday 04 July 2009 17:21:18 nikopol@xxxxxxx, vous avez écrit :
Le Saturday 04 July 2009 16:34:20 Guillaume Gardet, vous avez écrit :
Bonjour,

As-tu installé Sendmail par YaST ou zypper ? Quelle version et depuis
quel dépôt ?

A bientôt,
Guillaume

Je n'ai plus Sendmail mais Exim.
En suivant ce lien, tu as les versions et les paquages pour OpenSuSE
x86_64:

<http://fr2.rpmfind.net/linux/rpm2html/search.php?query=sendmail&submit=
Sea rch+...&system=opensuse&arch=x86_64>

De là, tu pioches celui qui te semble le mieux.

nikopol@xxxxxxx a écrit :
Le Saturday 04 July 2009 14:13:15 Laurent HENRY (EHESS/CRI), vous

avez

écrit :
Le Sam 4 juillet 2009 14:00, nikopol@xxxxxxx a écrit :
Le Saturday 04 July 2009 11:45:26 Laurent HENRY (EHESS/CRI), vous
avez

écrit :
Bonjour,
Je suis à la recherche d'un peu d'aide concernant un sendmail

sur

une opensuse 11.1 x64.

J'ai un sendmail qui tourne sur cette machine.

Quand j'essaye de recompiler la mailertable, j'obtiens:
smtp2a:/etc/mail # make
Rebuilding /etc/mail/mailertable.db.
makemap hash /etc/mail/mailertable.db < /etc/mail/mailertable
makemap: Need to recompile with -DNEWDB for hash support
make: *** [/etc/mail/mailertable.db] Erreur 73

ou encore:
smtp2a:/etc/mail # makemap hash mailertable.db < mailertable
makemap: Need to recompile with -DNEWDB for hash support

Je ne comprends pas car sur d'autres serveurs, a priori

identiques,

je ne
rencontre pas ce soucis.

Dans mon sendmail.mc:
FEATURE(`mailertable', `hash -o /etc/mail/mailertable.db')dnl

Ce qui donne dans le sendmail.cf
Kmailertable hash -o /etc/mail/mailertable.db


Mon sendmail est celui de la distribution:
smtp2a:/etc/mail # rpm -qa|grep sendmail
sendmail-devel-8.14.3-50.9
sendmail-8.14.3-50.9

En cherchant ce probleme sur google, j'ai vu que cela pouvait

etre

un probleme avec la libdb qui pourtant est bien là:
smtp2a:/etc/mail # locate libdb
(...)
/usr/lib64/libdb-4.5.a
/usr/lib64/libdb-4.5.so
/usr/lib64/libdb-4.so
/usr/lib64/libdb.a
/usr/lib64/libdb.so


Ou pourrais-je chercher ? (Sachant que je ne souhaite pas
(re)compiler sendmail, la version rpm me va)

Merci.

Salut,

Hélas je suis partis de Sendmail pour Exim ( il y a longtemps
maintenant ).
Pour ce que je me rappel, la construction de la table avec

Berkeley

DB en Hash
me semble correcte et "makemap" de devrait pas se plaindre.
Enfin, si "makemap" se plaignait de la lib "libdb-4.5.so", alors
Sendmail aussi et il ne pourrait plus courir...

Peut-être avec "ldd":
% ldd /usr/sbin/makemap

Bonne continuation.
--
To unsubscribe, e-mail: opensuse-fr+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-fr+help@xxxxxxxxxxxx

Oui, c'est vers cette piste que je me suis orienté aussi.
C'est incompréhensible pour moi:
Sur cette machine:
smtp:~ # cat /etc/SuSE-release ; uname -a
openSUSE 11.1 (x86_64)
VERSION = 11.1
Linux smtp 2.6.27.23-0.1-default #1 SMP 2009-05-26 17:02:05 -0400
x86_64 x86_64 x86_64 GNU/Linux
smtp:~ # rpm -qa|grep sendmail
sendmail-devel-8.14.3-50.9
sendmail-8.14.3-50.9
smtp:~ # ldd /usr/sbin/makemap
linux-vdso.so.1 => (0x00007fff769fe000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f0e6e54b000)
libssl.so.0.9.8 => /usr/lib64/libssl.so.0.9.8

(0x00007f0e6e2fd000)

libcrypto.so.0.9.8 => /usr/lib64/libcrypto.so.0.9.8
(0x00007f0e6df80000) libc.so.6 => /lib64/libc.so.6
(0x00007f0e6dc27000) /lib64/ld-linux-x86-64.so.2

(0x00007f0e6e74f000)

libz.so.1 => /lib64/libz.so.1 (0x00007f0e6da11000)


Sur une autre qui fonctionne correctement:
smtp2:~ # cat /etc/SuSE-release ;uname -a
openSUSE 11.1 (x86_64)
VERSION = 11.1
Linux smtp2 2.6.27.23-0.1-xen #1 SMP 2009-05-26 17:02:05 -0400

x86_64

x86_64 x86_64 GNU/Linux
smtp2:~ # rpm -qa|grep sendmail
sendmail-devel-8.14.3-50.9
sendmail-8.14.3-50.9
smtp2:~ # ldd /usr/sbin/makemap
linux-vdso.so.1 => (0x00007fff65dff000)
libdb-4.5.so => /usr/lib64/libdb-4.5.so (0x00007f605d6f1000)
libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2
(0x00007f605d4ad000) liblber-2.4.so.2 =>

/usr/lib64/liblber-2.4.so.2

(0x00007f605d29d000) libssl.so.0.9.8 => /usr/lib64/libssl.so.0.9.8
(0x00007f605d04f000) libcrypto.so.0.9.8 =>
/usr/lib64/libcrypto.so.0.9.8
(0x00007f605ccd2000) libsasl2.so.2 => /usr/lib64/libsasl2.so.2
(0x00007f605cab7000) libc.so.6 => /lib64/libc.so.6
(0x00007f605c75e000) libpthread.so.0 => /lib64/libpthread.so.0
(0x00007f605c542000) libdl.so.2 => /lib64/libdl.so.2
(0x00007f605c33e000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f605c127000)
libz.so.1 => /lib64/libz.so.1 (0x00007f605bf11000)
/lib64/ld-linux-x86-64.so.2 (0x00007f605da29000)

Effectivement, il manque libdb, entre autre. Comment est-ce

possible ?

Il semblerait que "makemap" ( du Tux récalcitrant ) ne soit pas

compilé

avec le support Berkeley DB => libdb.so ni OpenSSL => libssl.so ni
libpthread.so ?? Étrange.

Tu peux télécharger le rpm "sendmail-8.14.3-50.9.x86_64.rpm" puis le
décompresser avec "rpm2cpio " et "cpio" pour comparer:

% cd ~
% mkdir -p sendmail_rpm
% cd sendmail_rpm
% rpm2cpio sendmail-8.14.3-50.9.x86_64.rpm | cpio -idvd
% ldd usr/sbin/makemap

Étrange...

"rpm" peut donner quelques renseignements, comme par exemple la date
d'installation d'un paquage:

% rpm -qi sendmail | grep "Install Date"

Pour ce que je vois, il faut se tourner sur la possibilité d'avoir
"rebuilder"
Sendmail sans les librairies nécessaires.
Comment ??
Depuis le rpm source ?? peut-être, en choisissant le rpm source a la
place du
rpm compilé ( c'est possible, Yast le télécharge et le build avec les
librairies installées - sans glibc-devel-64bit pour
/usr/lib64/libpthread.so
et d'autres - pour l'installer finalement ) ??

Avec:
% rpm -qi sendmail

Tu auras plus de renseignement sur se mystère, en autre en jetant deux
yeux
sur le champ "Build Host" qui donne le nom de la machine qui a compilée
le rpm installé.

@+
nikopol

--
To unsubscribe, e-mail: opensuse-fr+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-fr+help@xxxxxxxxxxxx

Je pense avoir trouvé, je n'ai plus le makemap d'origine.


Mon install, vient du ftp.free.fr, je suis allé cherché le rpm, le makemap
qui est dedans est le bon avec les bonnes librairies.

Par contre, sur mon systeme, la date de mon makemap est suspecte, il date
d'apres la date d'installation et il n'y a pas eut de mise à jour sendmail
depuis.

smtp:~ # l /usr/sbin/makemap
-r-xr-xr-x 1 bin bin 106777 mai 29 22:03 /usr//sbin/makemap*

Je n'utilise pas la libmilter d'origine mais une version recompilée, cela
veut dire que j'ai aussi les sources de sendmail dans un coin.
Comme par hasard, mon makemap date du jour de l'install de ma libmilter
recompilée.
smtp:~ # ls -l sendmail.8.14.2.tar.gz
-rw-r--r-- 1 root root 2064346 mai 29 21:39 sendmail.8.14.2.tar.gz


Habituellement, je compile la partie qui m'interesse dans les sources et
je vais recopier ma libmilter sans installer le reste, je pense que
l'heure était suffisamment tardive ce 29 mai pour avoir aussi laché un
make install malencontreux et que j'ai ecrasé un certain nombre de choses,
dont le makemap.

Saches que le paquage "sendmail-devel" que tu as installé sur cette machine
contient :
- /usr/lib64/libmilter.a
- /usr/lib64/libsmutil.a
- /usr/lib64/libsm.a

Et de même que les headers de libmilter qui vont bien avec ta version de
Sendmail dans :
- /usr/include/libmilter
- /usr/include/sm

Utilisez des paquages sources recuisinné à sa sauce peut occasionner des
troubles presque impossible a déterminer avec un paquage de Sendmail compiler
avec d'autres options.

Le mieux, tout en restant avec une distribution maintenable, est de te faire
ton propre paquage RPM de Sendmail et Milter avec tes options depuis le RPM
source de OpenSuSE.

Personnellement, c'est ce que je fais pour tous les paquages serveurs, comme
le SMTP (Exim), POP (tpop3d) et WEB (lighttpd) .

+@
--
--
To unsubscribe, e-mail: opensuse-fr+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-fr+help@xxxxxxxxxxxx

< Previous Next >
List Navigation