Mailinglist Archive: opensuse-features (365 mails)

< Previous Next >
[openFATE 300689] TabletPC: Support Touchscreen and Wacom decives during installation
  • From: fate_noreply@xxxxxxx
  • Date: Tue, 2 Mar 2010 13:00:50 +0100 (CET)
  • Message-id: <feature-300689-43@xxxxxxxxxxxxxx>
Feature changed by: Stephan Kulow (coolo)
Feature #300689, revision 43
Title: TabletPC: Support Touchscreen and Wacom decives during
installation

openSUSE-10.3: Rejected by Stephan Kulow (coolo)
reject date: 2007-08-03 09:39:40
reject reason: installation is frozen
Priority
Requester: Desirable
Projectmanager: Desirable

openSUSE-11.1: Rejected by Stanislav Visnovsky (visnov)
reject date: 2008-07-16 09:02:38
reject reason: Postponing. Out of resources.
Priority
Requester: Important
Projectmanager: Important

openSUSE-11.2: Rejected by Michael Löffler (michl19)
reject date: 2009-04-16 12:28:26
reject reason: out of scope for 11.2
Priority
Requester: Important
Projectmanager: Important

openSUSE-11.3: Unconfirmed
Priority
Requester: Mandatory

Requested by: Stefan Behlert (sbehlert)

Description:
Tablet PCs are normally produced in two kinds of flavours:
Convertibles, which have a keyboard, and Slates, which have none (only
pens or touchscreens).
If a user installs a Slate, he has no keyboard and no (pohysical) mouse
device, only the touchscreen.
We should on TabletPCs automatically recognize that it is a TabletPC
and configure the Wacom or other Touchscreen device where possible.
Thus would enhance the usability of the product on TabletPCs.

Discussion:
#1: Gary Ekker (gekker) (2007-07-17 11:24:05)
Stefan, do you see this as work that your team would do, something that
needs to be done by the YaST installer, or both?

#6: Matthias Nagorni (mnagorni) (2009-08-24 13:17:30)
As long as there is a different way to install it, this appears only
like a "nice to have".

#7: Daniel FAIVRE (geomaticien) (2009-10-24 07:03:07)
There's now really few things to do that for 11.2 : see
http://en.opensuse.org/SDB:Howto_install_OpenSuSE_on_HP_tx2-xxxx_laptops
Furthermore, for 11.3, it should be mandatory !
To get this support for 11.1 or 11.2, we need to :
- replace hid-ntrig.c from 2.6.31 kernel by the up-to date version :
just copy/paste.
- patching linuxwacom : 4 lines to change.
- adding a sax2 profile for these devices in the sax2 cdb file.
(11.1 needs a kernel upgrade to a kernel from HEAD repository before)

#8: Daniel FAIVRE (geomaticien) (2009-10-24 07:28:09) (reply to #7)
Read too fast : my post concern support AFTER installation. Please take
care.

+ #9: Stephan Kulow (coolo) (2010-03-02 13:00:45) (reply to #8)
+ feel free to work on it and do submit requests against the devel
+ projects.



--
openSUSE Feature:
https://features.opensuse.org/300689

< Previous Next >
This Thread
  • No further messages