Mailinglist Archive: opensuse-factory (679 mails)

< Previous Next >
[opensuse-factory] Leap 42.3 Build 0277 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=42.3&build=0277&groupid=28
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2042.3

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=298435253
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
Mesa
autoyast2 (3.2.15 -> 3.2.16)
catdoc (0.94.4 -> 0.95)
ceph (12.0.3+git.1495798013.23dd2b67dc -> 12.0.3+git.1496909744.9f667dc335)
corosync
cups-pk-helper
file-roller
freetype2
git (2.13.0 -> 2.13.1)
gnome-control-center
gnome-settings-daemon
gnome-system-monitor
installation-images-openSUSE (14.317 -> 14.318)
libgtop (2.34.0 -> 2.34.1)
libqt5-qtbase
patterns-openSUSE
plasma-framework
rdma-core
shotwell
texlive
texlive-specs-m (2016.115.svn40218 -> 2016.122.svn40218)
texlive-specs-n (2016.113.2.004svn28119 -> 2016.122.2.004svn28119)
yast2-storage (3.2.14 -> 3.2.15)
yast2-trans (84.87.20161108.95adeff -> 84.87.20170607.40033d88)

=== Details ===

==== Mesa ====
Subpackages: Mesa-32bit Mesa-devel Mesa-dri-devel Mesa-libEGL-devel
Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit
Mesa-libGLESv1_CM-devel Mesa-libGLESv1_CM1 Mesa-libGLESv2-2
Mesa-libGLESv2-devel Mesa-libglapi-devel Mesa-libglapi0 Mesa-libglapi0-32bit
Mesa-libva libOSMesa-devel libOSMesa8 libOSMesa8-32bit libgbm-devel libgbm1
libgbm1-32bit libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libwayland-egl-devel libwayland-egl1 libxatracker2

- specfile: Remove requires to vulkan libs from baselibs.conf on
platforms where vulkan build is disabled; ugly ... (bsc#1042900)

==== autoyast2 ====
Version update (3.2.15 -> 3.2.16)
Subpackages: autoyast2-installation

- Report shrinked partitions if there is not enough space.
(bnc#1039528)
- 3.2.16

==== catdoc ====
Version update (0.94.4 -> 0.95)

- catdoc 0.95:
* Fix various issues found during fuzzing which may lead to an
application crash or have unspecified further impact when
the user is tricked into opening specially crafted files
bsc#919228
* Replace charset tables with new ones, published by Unicode
Consortium with more permissive license
* Fix some incompatibilities with CLang
* Fix lot of segfaults on incorrect or corrupted data
* Use stdint int types throughout the code
- drop install.patch

==== ceph ====
Version update (12.0.3+git.1495798013.23dd2b67dc ->
12.0.3+git.1496909744.9f667dc335)
Subpackages: librados2 librbd1

- Update to version 12.0.3+git.1496909744.9f667dc335:
+ build/ops: rpm: one License line to rule them all
- up memory _constraint for ceph-test to address ppc64le OOM seen in IBS
- Update to version 12.0.3+git.1496902753.b18dc53186:
+ build/ops: rpm, COPYING: drop GPL 2.0 with Autoconf Exception
(autoconf no longer used)
- Update to version 12.0.3+git.1496754880.35cb2861ce:
+ merge upstream master (b1d06a6b54)
- Update to version 12.0.3+git.1496494491.ba3c561a92:
+ merge upstream master (97d6e150e5)
- Update to version 12.0.3+git.1496306960.2db336d85e:
+ merge upstream master (b19352eec3), fixes bsc#1041492
- Update to version 12.0.3+git.1496147556.f1d6115861:
+ cmake: build boost::context and coroutine only with rgw Beast frontend
+ build/ops: rpm: reverse s390 bcond conditional block
+ build/ops: rpm: no rgw Beast frontend on s390x
+ build/ops: deb: no rgw Beast frontend on s390x
+ cmake: delete excidentail reintroduced line.
+ cmake: link radosgw with boost libraries
(bsc#1040119)
- Update to version 12.0.3+git.1495849076.4457d36178:
+ rgw: remove fastcgi from default rgw frontends
+ RGW: Turn off fcgi as a frontend
+ build/ops: drop libfcgi build dependency
+ build/ops: rpm: apply epoch only if %epoch macro is defined

==== corosync ====

- some Fixes from upstream(bsc#1043045)
Added: 0004-main-Display-reason-why-cluster-cannot-be-formed.patch
0005-votequorum-Report-errors-from-votequorum_exec_send_r.patch
0006-coroapi-Use-size_t-for-private_data_size.patch

==== cups-pk-helper ====
Subpackages: cups-pk-helper-lang

- Add enable-utf8-chars-in-printer-name.patch to handle the
printers names containing UTF-8 characters (bsc#1033742,
rh#982727).

==== file-roller ====
Subpackages: file-roller-lang nautilus-file-roller

- Add file-roller-fix-integer-overflow.patch
- Add file-roller-show-dialog-only-when-notify.patch
- Add file-roller-fix-crash-extracting-file.patch
(bsc#1022082, bgo#778846)

==== freetype2 ====
Subpackages: freetype2-devel libfreetype6 libfreetype6-32bit

- Add bsc-1038506.patch from upstream to fix unifont bsc#1038506

==== git ====
Version update (2.13.0 -> 2.13.1)
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- git 2.13.1:
* Setting "log.decorate=false" in the configuration file did not
take effect in v2.13, which has been corrected.
* corrections to documentation and command help output
* garbage collection fixes
* memory leaks fixed
* receive-pack now makes sure that the push certificate records
the same set of push options used for pushing
* shell completion corrections for git stash
* fix "git clone --config var=val" with empty strings
* internal efficiency improvements
* Update sha1 collision detection code for big-endian platforms
and platforms not supporting unaligned fetches
- Fix packaging of documentation

==== gnome-control-center ====
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Add gnome-control-center-info-disc-size-for-btrfs.patch:
Fix total disc size for btrfs subvolumes displayed in info panel,
backported upstream commit b619f7c (bsc#890385, bsc#1037234,
bgo#708786).

==== gnome-settings-daemon ====
Subpackages: gnome-settings-daemon-lang

- Add gnome-settings-daemon-keybindings-become-unavaiable.patch:
Fix some keybindings become unavailable. Include upstream commits
8966dd9, 7d15e66, e980c09, 61be0fa, 2600ac4.
(bsc#1000599 bgo#758302)

==== gnome-system-monitor ====
Subpackages: gnome-system-monitor-lang

- Add gsm-bsc1020294-add-resources-scrollbar.patch: add a
scrollbar to the resources tab (bsc#1020294, bgo#778697).

==== installation-images-openSUSE ====
Version update (14.317 -> 14.318)

- merge gh#openSUSE/installation-images#187
- leap-42.3: include video drivers from drm-kmp (bsc#1043146)
- 14.318

==== libgtop ====
Version update (2.34.0 -> 2.34.1)
Subpackages: libgtop-2_0-10 libgtop-devel libgtop-lang typelib-1_0-GTop-2_0

- Add libgtop-bsc1020294-cpu-buffer.patch: dynamically allocate
memory for buffer when reading /proc/cpuinfo (bsc#1020294
bgo#323354).
- Fix build on SLE: pass "po libgtop" to
translation-update-upstream: it fails do detect the correct
gettext domain.
- Update to version 2.34.1:
+ Rename --with-libgtop-examples to --with-examples.
+ Use gettext instead of intltool/glib-gettext.
+ Added Language headers to the translations.
- Drop intltool BuildRequires following upstream changes.
- Remove obsolete clean section, and conditionals for long gone
versions of openSUSE.
- Make translation-update-upstream conditional, only apply on
non-openSUSE.

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent-devel libQt5Concurrent5 libQt5Core-devel
libQt5Core-private-headers-devel libQt5Core5 libQt5DBus-devel libQt5DBus5
libQt5Gui-devel libQt5Gui-private-headers-devel libQt5Gui5 libQt5Network-devel
libQt5Network5 libQt5OpenGL-devel libQt5OpenGL5 libQt5PlatformHeaders-devel
libQt5PrintSupport-devel libQt5PrintSupport5 libQt5Sql-devel libQt5Sql5
libQt5Sql5-mysql libQt5Sql5-postgresql libQt5Sql5-sqlite libQt5Sql5-unixODBC
libQt5Test-devel libQt5Test5 libQt5Widgets-devel libQt5Widgets5 libQt5Xml-devel
libQt5Xml5 libqt5-qtbase-common-devel libqt5-qtbase-devel

- Add upstream patch to fix various HiDPI-related issues:
* native-children-hidpi-offset.patch (QTBUG-59017, kde#363548, bsc#1042337)

==== patterns-openSUSE ====
Subpackages: patterns-openSUSE-apparmor patterns-openSUSE-apparmor_opt
patterns-openSUSE-base patterns-openSUSE-books patterns-openSUSE-console
patterns-openSUSE-devel_C_C++ patterns-openSUSE-devel_basis
patterns-openSUSE-devel_gnome patterns-openSUSE-devel_ide
patterns-openSUSE-devel_java patterns-openSUSE-devel_kde
patterns-openSUSE-devel_kde_frameworks patterns-openSUSE-devel_kernel
patterns-openSUSE-devel_perl patterns-openSUSE-devel_python
patterns-openSUSE-devel_python3 patterns-openSUSE-devel_qt4
patterns-openSUSE-devel_qt5 patterns-openSUSE-devel_rpm_build
patterns-openSUSE-devel_ruby patterns-openSUSE-devel_web
patterns-openSUSE-dhcp_dns_server patterns-openSUSE-directory_server
patterns-openSUSE-enhanced_base patterns-openSUSE-enhanced_base_opt
patterns-openSUSE-file_server patterns-openSUSE-fonts
patterns-openSUSE-fonts_opt patterns-openSUSE-games
patterns-openSUSE-gateway_server patterns-openSUSE-generic_server
patterns-openSUSE-gnome patterns-openSUSE-gnome_admin pattern
s-openSUSE-gnome_basis patterns-openSUSE-gnome_basis_opt
patterns-openSUSE-gnome_games patterns-openSUSE-gnome_ide
patterns-openSUSE-gnome_imaging patterns-openSUSE-gnome_imaging_opt
patterns-openSUSE-gnome_internet patterns-openSUSE-gnome_laptop
patterns-openSUSE-gnome_multimedia patterns-openSUSE-gnome_multimedia_opt
patterns-openSUSE-gnome_office patterns-openSUSE-gnome_office_opt
patterns-openSUSE-gnome_utilities patterns-openSUSE-gnome_yast
patterns-openSUSE-imaging patterns-openSUSE-imaging_opt patterns-openSUSE-kde
patterns-openSUSE-kde_edutainment patterns-openSUSE-kde_games
patterns-openSUSE-kde_ide patterns-openSUSE-kde_imaging
patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma
patterns-openSUSE-kde_telepathy patterns-openSUSE-kde_utilities
patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast
patterns-openSUSE-kvm_server patterns-openSUSE-lamp_server
patterns-openSUSE-laptop patterns-openSUSE-
lxde patterns-openSUSE-lxde_laptop patterns-openSUSE-lxde_office
patterns-openSUSE-mail_server patterns-openSUSE-minimal_base
patterns-openSUSE-minimal_base-conflicts patterns-openSUSE-misc_server
patterns-openSUSE-multimedia patterns-openSUSE-multimedia_opt
patterns-openSUSE-network_admin patterns-openSUSE-non_oss
patterns-openSUSE-non_oss_opt patterns-openSUSE-office
patterns-openSUSE-office_opt patterns-openSUSE-print_server
patterns-openSUSE-remote_desktop patterns-openSUSE-rest_dvd
patterns-openSUSE-sw_management patterns-openSUSE-sw_management_gnome
patterns-openSUSE-sw_management_kde patterns-openSUSE-tabletpc
patterns-openSUSE-technical_writing patterns-openSUSE-update_test
patterns-openSUSE-x11 patterns-openSUSE-x11_opt patterns-openSUSE-x11_yast
patterns-openSUSE-xen_server patterns-openSUSE-xfce
patterns-openSUSE-xfce_basis patterns-openSUSE-xfce_laptop
patterns-openSUSE-xfce_office patterns-openSUSE-yast2_basis
patterns-openSUSE-yast2_install_wf

- include drm-kmp-default on medias (boo#1043146)

==== plasma-framework ====
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-lang plasma-framework-private

- Add upstream patches to fix appearance of hovered toolbuttons
(like the sddm session selection):
* 0002-don-t-switch-colors-on-new-themes.patch
* 0003-Emit-usedPrefixChanged-when-prefix-is-empty.patch

==== rdma-core ====
Subpackages: libibverbs1 librdmacm1

- Add patch rdma-core-s390x.patch to fix s390x build (bsc#1043105).
* Add missing verbs providers for s390x
* Add mlx5 package for s390x
- libibverbs1 requires libibverbs (bsc#1042840).

==== shotwell ====
Subpackages: shotwell-lang

- add shotwell-facebook-id.patch: update Facebook id (bsc#943556
bgo#748991).

==== texlive ====

- Switch over from 20160523 source tree to 20160523b
as it includes someminor bug fixes
- Use lua compatible configuration for TEXMFCNF in texmf.cnf

==== texlive-specs-m ====
Version update (2016.115.svn40218 -> 2016.122.svn40218)

- Back to old fontspec 2.5a
* Yes it is buggy but it fits the LaTeX kernel engine
- Readd patch fontspec_emph.dif for bug boo#1039951
- The file texmfcnf.lua is a main configuration file
- Use lua compatible configuration for TEXMFCNF in texmf.cnf
- Remove patch fontspec_emph.dif and update fontspec to version 2.6a
which does hopefully fix those nasty bugs boo#1039951, boo#1040434
- Readd the old font config and fd files from old fontspec package
as the next TeXLive version will have them in the latex package
- Add patch fontspec_emph.dif for bug boo#1039951
nasty \emph-related bugs in texlive-fontspec package
- Allow updmap to run as batch job if stdin if not connected on
a termionl (boo#1033068)

==== texlive-specs-n ====
Version update (2016.113.2.004svn28119 -> 2016.122.2.004svn28119)

- Back to old fontspec 2.5a
* Yes it is buggy but it fits the LaTeX kernel engine
- Readd patch fontspec_emph.dif for bug boo#1039951
- The file texmfcnf.lua is a main configuration file
- Use lua compatible configuration for TEXMFCNF in texmf.cnf
- Remove patch fontspec_emph.dif and update fontspec to version 2.6a
which does hopefully fix those nasty bugs boo#1039951, boo#1040434
- Readd the old font config and fd files from old fontspec package
as the next TeXLive version will have them in the latex package
- Add patch fontspec_emph.dif for bug boo#1039951
nasty \emph-related bugs in texlive-fontspec package
- Allow updmap to run as batch job if stdin if not connected on
a termionl (boo#1033068)
- Modify patch kpathsea_cnf.dif to remove mpost from the allowed
shell escaping commands (bsc#1028271, CVE-2016-10243)
- Add some lines to %post scriplet for kpathsea to remove mpost
also from an already existing but not becoming replaced
configuration file texmf.cnf

==== yast2-storage ====
Version update (3.2.14 -> 3.2.15)

- Fixed UI syntax error when adding tmpfs (bsc#1041737)
- 3.2.15

==== yast2-trans ====
Version update (84.87.20161108.95adeff -> 84.87.20170607.40033d88)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en_GB yast2-trans-en_US
yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi yast2-trans-fr
yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr yast2-trans-hu
yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv yast2-trans-ka
yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt yast2-trans-mk
yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa yast2-trans-pl
yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru yast2-trans-si
yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20170607.40033d88:
* Add rpm-groups-pot-update.sh
* Automatic update of add-on.
* Automatic update of alternatives.
* Automatic update of base.
* Automatic update of cio.
* Automatic update of control.
* Automatic update of firstboot.
* Automatic update of gtk.
* Automatic update of installation.
* Automatic update of iscsi-lio-server.
* Automatic update of registration.
* Automatic update of storage.
* Change Plural-Forms of lt
* Consistent heading levels
* Describe translation process
* Fixing merge_pot function.
* New POT for text domain 'add-on'.
* New POT for text domain 'alternatives'.
* New POT for text domain 'auth-client'.
* New POT for text domain 'autoinst'.
* New POT for text domain 'base'.
* New POT for text domain 'bootloader'.
* New POT for text domain 'cio'.
* New POT for text domain 'cluster'.
* New POT for text domain 'control'.
* New POT for text domain 'country'.
* New POT for text domain 'crowbar'.
* New POT for text domain 'dhcp-server'.
* New POT for text domain 'dns-server'.
* New POT for text domain 'firewall'.
* New POT for text domain 'firstboot'.
* New POT for text domain 'fonts'.
* New POT for text domain 'gtk'.
* New POT for text domain 'http-server'.
* New POT for text domain 'installation'.
* New POT for text domain 'iscsi-client'.
* New POT for text domain 'iscsi-lio-server'.
* New POT for text domain 'kdump'.
* New POT for text domain 'multipath'.
* New POT for text domain 'ncurses-pkg'.
* New POT for text domain 'network'.
* New POT for text domain 'ntp-client'.
* New POT for text domain 'packager'.
* New POT for text domain 'product-creator'.
* New POT for text domain 'qt'.
* New POT for text domain 'rear'.
* New POT for text domain 'registration'.
* New POT for text domain 'reipl'.
* New POT for text domain 'samba-server'.
* New POT for text domain 'scanner'.
* New POT for text domain 'services-manager'.
* New POT for text domain 'storage'.
* New POT for text domain 'storage-ng'.
* New POT for text domain 'tune'.
* New POT for text domain 'update'.
* New POT for text domain 'users'.
* New POT for text domain 'vm'.
* New POT for text domain 'yast2-apparmor'.
* Remove obsolete pot files
* Removed a '&' from german translation for a label.
* Translated using Weblate (Arabic)
* Translated using Weblate (Asturian)
* Translated using Weblate (Belarusian)
* Translated using Weblate (Bulgarian)
* Translated using Weblate (Catalan)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Czech)
* Translated using Weblate (Danish)
* Translated using Weblate (Dutch)
* Translated using Weblate (English (United Kingdom))
* Translated using Weblate (Estonian)
* Translated using Weblate (Finnish)
* Translated using Weblate (French)
* Translated using Weblate (Galician)
* Translated using Weblate (German)
* Translated using Weblate (Greek)
* Translated using Weblate (Hebrew)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Italian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Korean)
* Translated using Weblate (Lithuanian)
* Translated using Weblate (Norwegian Bokmål)
* Translated using Weblate (Norwegian Nynorsk)
* Translated using Weblate (Persian)
* Translated using Weblate (Polish)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Russian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Spanish (Argentina))
* Translated using Weblate (Spanish)
* Translated using Weblate (Ukrainian)
* Translated using Weblate (xh (generated))
* Uncomment 'y2m update'
* Update DOMAIN_MAP
* Update README.md
* Update of rpm-groups.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >